Bug #91412

Password recovery mail of felogin sends empty HTML part

Added by Andreas Fernandez 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
felogin
Target version:
Start date:
2020-05-15
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
Yes
Sprint Focus:

Description

The template PasswordRecovery.html misses the SystemEmail layout, thus no HTML part is rendered and sent at all.


Related issues

Related to TYPO3 Core - Task #90729: Migrate Felogin mail to FluidEmail Closed 2020-03-10

Associated revisions

Revision c6863067 (diff)
Added by Andreas Fernandez about 2 months ago

[BUGFIX] Use SystemEmail layout in felogin password recovery

The PasswordRecovery template misses a layout which results in an empty
HTML part being rendered. This patch adds the layout and renders our
marvellous HTML mails again.

The plaintext part missed the layout as well, which caused to miss some
additional information available in the mails.

Resolves: #91412
Related: #90729
Releases: master
Change-Id: Ic883aefa5ae88783d0c74d2c7843d1e8445461ab
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/64498
Tested-by: TYPO3com <>
Tested-by: Annett Jähnichen <>
Tested-by: Oliver Bartsch <>
Tested-by: Josef Glatz <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Annett Jähnichen <>
Reviewed-by: Oliver Bartsch <>
Reviewed-by: Josef Glatz <>
Reviewed-by: Andreas Fernandez <>

History

#1 Updated by Andreas Fernandez 2 months ago

  • Related to Task #90729: Migrate Felogin mail to FluidEmail added

#2 Updated by Gerrit Code Review 2 months ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64498

#3 Updated by Gerrit Code Review 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64498

#4 Updated by Annett Jähnichen 2 months ago

  • Subject changed from Password recovery mail of felogin sends empts HTML part to Password recovery mail of felogin sends empty HTML part

#5 Updated by Annett Jähnichen 2 months ago

Since version 10.4.0

<f:layout name="SystemEmail" />

misses in

typo3/sysext/felogin/Resources/Private/Email/Templates/PasswordRecovery.html

Patch works for me with TYPO3 v10.4.2.

#6 Updated by Andreas Fernandez about 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Benni Mack about 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF