Bug #91460

Page tree not visible for backend group - Page tree error - Got unexpected response from the server.

Added by Andrreas Lehmann 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2020-05-22
Due date:
% Done:

0%

TYPO3 Version:
10
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Reproduction:

  • Installing normal TYPO3 10.4.3 (also dont works with 9.5.11)
  • Logged in a „admin“
  • Created a new page „Test“ as
  • Root page CHECK
  • Page visible CHECK
  • Creating a Backend usergroup with name „Reaktion“ and gave him under „Access Lists“ all rights
  • Creating a Backend user „a.b“ and put him in the group „Redaktion“
  • Changed in access the Test page to the Group „Redaktion“
  • Logged in as user „a.b“
  • When calling the page, there is no Root „New TYPO3 site“ and no „Test“ page

Error: Page tree error - Got unexpected response from the server.

Log:

Fri, 22 May 2020 14:53:16 +0200 [CRITICAL] request="3ca52ab9ef87d" component="TYPO3.CMS.Core.Error.DebugExceptionHandler": Core: Exception handler (WEB): Uncaught TYPO3 Exception: syntax error, unexpected 'if' (T_IF) | ParseError thrown in file /kunden/431424_13355/webseiten/subdomains/typo3_src-10.4.3/typo3/sysext/backend/Classes/Controller/Page/TreeController.php in line 301. Requested URL: http://qs.dega-akustik.de/typo3/index.php?route=%2Fajax%2Fpage%2Ftree%2FfetchConfiguration&token=--AnonymizedToken-- - {"TYPO3_MODE":"BE","exception":{}}

Error seems to be in /webseiten/subdomains/typo3_src-10.4.3/typo3/sysext/backend/Classes/Controller/Page/TreeController.php in line 269

Tryed in 9.5.11

if ($this->useNavTitle && trim($page['nav_title'] ?? '') !== '') {

CHANGE TO

$navTitleTrim = isset($page['nav_title']) ? $page['nav_title'] : '';
     if (is_null($navTitleTrim)) {
         $navTitleTrim = '';
     }
        if ($this->useNavTitle && trim($navTitleTrim) !== '') {
            $nameSourceField = 'nav_title';
            $visibleText = $page['nav_title'];
        }
     if (is_null($visibleText)) {
         $visibleText = '';
     }

was working. In TYPO3 v10 not working anymore.

01.png View (46 KB) Andrreas Lehmann, 2020-05-22 15:27

Unbenannt.png View (60 KB) Andrreas Lehmann, 2020-06-02 21:00

History

#1 Updated by Andrreas Lehmann 5 months ago

  • Description updated (diff)

#2 Updated by Andreas Fernandez 5 months ago

  • Status changed from New to Needs Feedback

Can you please check whether the request really uses PHP 7.2 or newer? Since a syntax error is reported, I assume some PHP version is used that is not capable of the null coalesce operator (which came in with PHP 7.0!). Your proposed workaround is suitable for PHP < 7.0.

#3 Updated by Andrreas Lehmann 5 months ago

  • PHP Version changed from 7.2 to 7.3

I was taking a look in the backend. It is "PHP Version 7.3.10".

#4 Updated by Andreas Fernandez 5 months ago

I really wonder what's wrong here. Can you check if PHP 7.3 is also used for that very request that fails? I assume a pretty broked server setup here.

#5 Updated by Andrreas Lehmann 5 months ago

How i can find that out? I am not into debugging.

#6 Updated by Andrreas Lehmann 5 months ago

Was calling phpinfo() inside TreeController.php with

ob_start();
    phpinfo();
    $info = ob_get_contents();
    ob_end_clean();

    $fp = fopen("222.txt", "w+");
    fwrite($fp, $info);
    fclose($fp);

Result is, that PHP 7.3.10 is used.

#7 Updated by Oliver Hader 4 months ago

  • Target version deleted (9.5.18 & 10.4.3)

#8 Updated by Andrreas Lehmann 4 months ago

Hello TYPO3 Team,
what is the actual status here? Webserver problem or general problem?

#9 Updated by Andrreas Lehmann 4 months ago

Problem is solved in TYPO3 10.4.4

#10 Updated by Riccardo De Contardi 4 months ago

@Andrreas Lehmann thank you for the update. Do you think that this issue can be closed or is there still work to be done here?

#11 Updated by Andrreas Lehmann 4 months ago

Close it please.

#12 Updated by Riccardo De Contardi 4 months ago

  • Status changed from Needs Feedback to Closed

Closed in agreement with the reporter. If you think that this is the wrong decision, please reopen it or ping me.

Thank you!

Also available in: Atom PDF