Project

General

Profile

Actions

Bug #91497

closed

Fluid-based Page Module crashes with 2 language variants

Added by Niels Langlotz over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2020-05-26
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

With two language variants and active fluid based page module, this is not displayed correctly. When clicking on any page in the backend, the error message shown in the screenshot is displayed and the module cannot be used.

Return value of TYPO3\CMS\Backend\ViewHelpers\LanguageColumnViewHelper::render() must be an instance of TYPO3\CMS\Backend\View\BackendLayout\Grid\GridColumn, null returned

Tested under 10.4.3


Files


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Epic #90812: Fluid-based Page ModuleClosedBenni Mack2020-03-02

Actions
Actions #1

Updated by Alexander Grein over 3 years ago

I can confirm this problem.

It also exists if more than two languages exists.

The only way to "fix" the problem is currently to disable the fluid based page module feature.

Actions #2

Updated by Georg Tiefenbrunn over 3 years ago

Just to add some details (TYPO3 10.4.6 composer)

Steps to reproduce

1. Enable Fluid-based Page Module
2. Create a page inside a site with multiple languages
3. Apply a BE layout using colCount = 0 and rowCount = 0
4. Open the page in page module and switch from "Columns" to "Languages" using the action-menu (&SET[function]=2)

I alway apply an "empty" BE layout to e.g. sysfolders, external links, shortcuts etc. to prevent users from creating content elements.

Actions #3

Updated by Georg Tiefenbrunn over 3 years ago

  • Related to Epic #90812: Fluid-based Page Module added
Actions #4

Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65808

Actions #5

Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65808

Actions #6

Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65820

Actions #7

Updated by Georg Ringer over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #8

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed
Actions #9

Updated by Jan Delius over 2 years ago

This bug is back since https://forge.typo3.org/issues/92482. The condition was removed there.

Actions

Also available in: Atom PDF