Project

General

Profile

Actions

Bug #91763

closed

Mail file spool is broken

Added by Remo H. almost 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Miscellaneous
Target version:
-
Start date:
2020-07-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

There are two issues:
1) Mails (SentMessage) can not be serialized
2) FluidEmail calls generateTemplatedBody() in ensureValidity which leads to a null pointer exception for view when queued email is actually send

Solutions:
1) In FileSpool::doSend serialize orgiginal message: $ser = serialize($message->getOriginalMessage());
2) Only generate body if text and html body is empty


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #92053: Test Mail Setup: Serializer ExceptionClosed2020-08-20

Actions
Related to TYPO3 Core - Task #92394: bug fixes for file spoolingClosed2020-09-24

Actions
Actions #1

Updated by Simon Gilli over 3 years ago

  • Related to Bug #92053: Test Mail Setup: Serializer Exception added
Actions #3

Updated by Riccardo De Contardi over 3 years ago

  • Related to Task #92394: bug fixes for file spooling added
Actions #4

Updated by Riccardo De Contardi over 3 years ago

patch from #92394 could help?

Actions #5

Updated by Simon Gilli almost 3 years ago

Yes, patch of #92394 should solve the second issue now.

Actions #6

Updated by Benni Mack over 2 years ago

  • Status changed from New to Closed

Closing this issue now as well, since #92394 is merged.

Actions

Also available in: Atom PDF