Bug #91871

Error tag in scheduler does not have the message as title attribute anymore

Added by Stefan P 18 days ago. Updated about 16 hours ago.

Status:
Resolved
Priority:
Should have
Assignee:
Category:
scheduler
Target version:
-
Start date:
2020-07-27
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

I'm not sure whether this went gone in a TYPO3 9 minor update or if this was already gone on the intial 9 release.

In TYPO3 the red "error" "tag" on failed scheduler tasks had the message as title tag to show you what went wrong. This was really helpful. In TYPO3 9 we are left alone with nothing, making it very hard to debug errors on scheduler tasks.

I had this with custom Symfony tasks as well as with the core ones (referenceindex:update - I still don't know why this fails when executed from Scheduler context at all because the missing title tag - it's running flalessly when started manuall on the CLI).

Please bring back the error message as a title tag.


Related issues

Related to TYPO3 Core - Feature #45535: Sorting for scheduler-list Closed 2013-02-16

Associated revisions

Revision e119ea80 (diff)
Added by Georg Ringer about 17 hours ago

[BUGFIX] Fix typo to show label description of tasks again

Fix a typo in the variable name to show possible descriptions again.
This is especially useful if a task failed because it contains the
actual error message.

It has been broken since the refactoring to fluid.

Resolves: #91871
Releases: master, 10.4, 9.5
Change-Id: I8cd1ed8268e810ca505bc74728db62ac229c034f
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/65313
Reviewed-by: Richard Haeser <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Björn Jacob <>
Reviewed-by: Georg Ringer <>
Tested-by: Andreas Fernandez <>
Tested-by: TYPO3com <>
Tested-by: Björn Jacob <>
Tested-by: Georg Ringer <>

Revision ad3ffdc1 (diff)
Added by Georg Ringer about 17 hours ago

[BUGFIX] Fix typo to show label description of tasks again

Fix a typo in the variable name to show possible descriptions again.
This is especially useful if a task failed because it contains the
actual error message.

It has been broken since the refactoring to fluid.

Resolves: #91871
Releases: master, 10.4, 9.5
Change-Id: I8cd1ed8268e810ca505bc74728db62ac229c034f
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/65295
Tested-by: TYPO3com <>
Tested-by: Georg Ringer <>
Reviewed-by: Georg Ringer <>

Revision 2e2ac3c1 (diff)
Added by Georg Ringer about 16 hours ago

[BUGFIX] Fix typo to show label description of tasks again

Fix a typo in the variable name to show possible descriptions again.
This is especially useful if a task failed because it contains the
actual error message.
It has been broken since the refactoring to fluid.

Resolves: #91871
Releases: master, 10.4, 9.5
Change-Id: I8cd1ed8268e810ca505bc74728db62ac229c034f
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/65314
Tested-by: TYPO3com <>
Tested-by: Georg Ringer <>
Reviewed-by: Georg Ringer <>

History

#1 Updated by Stefan P 18 days ago

  • Subject changed from Erro tag in scheduler does not have the message as title tag anymore to Error tag in scheduler does not have the message as title tag anymore

#2 Updated by Stefan P 18 days ago

  • Subject changed from Error tag in scheduler does not have the message as title tag anymore to Error tag in scheduler does not have the message as title attribute anymore

#3 Updated by Georg Ringer about 18 hours ago

  • Status changed from New to Accepted
  • Assignee set to Georg Ringer

#4 Updated by Georg Ringer about 18 hours ago

#5 Updated by Georg Ringer about 18 hours ago

broken since #45535, will fix it

#6 Updated by Gerrit Code Review about 18 hours ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65313

#7 Updated by Gerrit Code Review about 17 hours ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65295

#8 Updated by Georg Ringer about 17 hours ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Gerrit Code Review about 17 hours ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65314

#10 Updated by Georg Ringer about 16 hours ago

  • Status changed from Under Review to Resolved

Also available in: Atom PDF