Bug #92067

Delete drop zone is created multiple times when just clicking on a page in page tree

Added by Helmut Hummel 10 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2020-08-21
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

This behaviour can be observed when inspecting the DOM of the SVG.
It has no severe visual effect, exept that the focus indicator (since 10.4)
exceeds right bounds for every page that has been selected at least once.


Files

Screen Shot 2020-08-21 at 16.34.06.png (13.3 KB) Screen Shot 2020-08-21 at 16.34.06.png never selected Helmut Hummel, 2020-08-21 16:36
Screen Shot 2020-08-21 at 16.34.24.png (12.8 KB) Screen Shot 2020-08-21 at 16.34.24.png selected once Helmut Hummel, 2020-08-21 16:36
Screen Shot 2020-08-21 at 16.31.42.png (193 KB) Screen Shot 2020-08-21 at 16.31.42.png multiple drop zones Helmut Hummel, 2020-08-21 16:36
#1

Updated by Gerrit Code Review 10 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65406

#2

Updated by Gerrit Code Review 10 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65406

#3

Updated by Oliver Hader 10 months ago

  • Category set to Pagetree
#4

Updated by Oliver Hader 10 months ago

It's in TYPO3 v10+ only, correct?

#5

Updated by Helmut Hummel 10 months ago

Oliver Hader wrote:

It's in TYPO3 v10+ only, correct?

No. It's directly visible in 10+ because of the focus outline, but the issue exists in 9.5 as well.

But it maybe isn't a priority bugifx, as it might not have much relevance. The bug only is, that the SVG dom grows with every click on a page. After a reload, these unneeded DOM elements are however gone again.

#6

Updated by Gerrit Code Review 10 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65406

#7

Updated by Gerrit Code Review 10 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65406

#8

Updated by Gerrit Code Review 9 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65793

#9

Updated by Gerrit Code Review 9 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65794

#10

Updated by Helmut Hummel 9 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#11

Updated by Benni Mack 9 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF