Feature #92088

Usage of modern image formats

Added by Christoph Werner 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2020-08-24
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

Hi!

It would be great to think about usage of modern images formats like JPEG 2000, JPEG XR, WebP, Avif (https://reachlightspeed.com/blog/using-the-new-high-performance-avif-image-format-on-the-web-today/) in TYPO3.

Main problem could be, that not all browses/devices support these formats (see https://caniuse.com/avif, https://caniuse.com/webp, https://caniuse.com/jpeg2000, https://caniuse.com/jpegxr). So a fallback solution would be great, maybe something like:

<picture>
    <source srcset="image.webp" type="image/webp">
    <source srcset="image.jpg" type="image/jpeg">
    <img src="image.jpg">
</picture>

Possible solution: A editor should be capable of adding two or more version of an image. But makes only sense, if the server could handle these formats.

There´s already a discussion about webp in #88537.

Best,
Christoph


Related issues

Is duplicate of TYPO3 Core - Feature #88537: WebP image format supportNeeds Feedback2019-06-11

Actions
#1

Updated by Georg Ringer 3 months ago

Now the new thing is https://reachlightspeed.com/blog/using-the-new-high-performance-avif-image-format-on-the-web-today/.

For webp I would check out the webp extension

#2

Updated by Oliver Hader 3 months ago

  • Status changed from New to Closed

Let's handle that at one place, please → #88537

#3

Updated by Oliver Hader 3 months ago

Also available in: Atom PDF