Task #92223

Build/Scripts/runTests.sh -s lintTypescript does not find task "tslint"

Added by Sybille Peters 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Tests
Target version:
-
Start date:
2020-09-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
tests,core development,lint
Complexity:
easy
Sprint Focus:

Description

The script runTests.sh runs with Docker. It does not find the task "tslint"

Build/Scripts/runTests.sh -s lintTypescript
Creating network "local_default" with the default driver
yarn install v1.21.1
[1/5] Validating package.json...
[2/5] Resolving packages...
success Already up-to-date.
$ patch-package
patch-package 6.2.2
Applying patches...
No patch files found
Done in 1.59s.
Warning: Task "tslint" not found. Use --force to continue.

Aborted due to warnings.


Related issues

Related to TYPO3 Core - Task #89232: Start using ESLint in favor of TSLintClosed2019-09-23

Actions
#1

Updated by Oliver Hader 3 months ago

Confirmed, this has been changed in https://review.typo3.org/c/Packages/TYPO3.CMS/+/61784/8/Build/Gruntfile.js from tslint (which is still called in docker compose commands) to eslint. This was introduce for TYPO3 v10.1.0

#2

Updated by Oliver Hader 3 months ago

  • Related to Task #89232: Start using ESLint in favor of TSLint added
#3

Updated by Oliver Hader 3 months ago

  • Status changed from New to Accepted
  • TYPO3 Version changed from 11 to 10
#4

Updated by Oliver Hader 3 months ago

  • Complexity set to easy
#5

Updated by Gerrit Code Review 3 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65637

#6

Updated by Gerrit Code Review 3 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65603

#7

Updated by Sybille Peters 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF