Task #92298

phpstan related changes to DependencyInjection caused wrong type declaration

Added by Benjamin Franzke 9 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Start date:
2020-09-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

https://review.typo3.org/c/Packages/TYPO3.CMS/+/65685

In ServiceProviderRegistry::create Package argument was changed to PackageInterface,
but the method getServiveProvider() is not available on the Interface.
Package was declared as type (instead of PackageInterface) by intent.


Related issues

Related to TYPO3 Core - Task #92110: Fix phpstan checkFunctionArgumentTypes errors in ext:coreClosed2020-09-10

Actions
Is duplicate of TYPO3 Core - Bug #92491: ServiceProviderRegistry->create must not have PackageInterface type hintedClosedDaniel Goerz2020-10-06

Actions
#1

Updated by Benjamin Franzke 9 months ago

  • Related to Task #92110: Fix phpstan checkFunctionArgumentTypes errors in ext:core added
#2

Updated by Gerrit Code Review 9 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65709

#3

Updated by Daniel Goerz 8 months ago

  • Is duplicate of Bug #92491: ServiceProviderRegistry->create must not have PackageInterface type hinted added
#4

Updated by Daniel Goerz 8 months ago

  • Status changed from Under Review to Closed

This was fixed with #92491

Also available in: Atom PDF