Bug #92460

render only default elements in page module language mode

Added by Georg Ringer about 1 year ago. Updated about 1 month ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend User Interface
Target version:
-
Start date:
2020-10-01
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If the page module is set to use the language mode and the default language is selected (which is the default), all elements in all languages are shown.


Related issues

Related to TYPO3 Core - Bug #95161: Empty grid when switching from "languages" to "columns" modeClosedOliver Bartsch2021-09-09

Actions
Related to TYPO3 Core - Bug #95308: Module Menu in web>layout should not display "All languages" when only default language existsClosedOliver Bartsch2021-09-21

Actions
Related to TYPO3 Core - Bug #95387: Page module shows wrong "All languages" option in "columns" modeClosed2021-09-28

Actions
#1

Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65970

#2

Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65970

#3

Updated by Gerrit Code Review about 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65970

#4

Updated by Gerrit Code Review 3 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65970

#5

Updated by Gerrit Code Review 3 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65970

#6

Updated by Georg Ringer 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Benni Mack about 1 month ago

  • Status changed from Resolved to Closed
#8

Updated by Oliver Bartsch about 1 month ago

  • Related to Bug #95161: Empty grid when switching from "languages" to "columns" mode added
#9

Updated by Oliver Bartsch 29 days ago

  • Related to Bug #95308: Module Menu in web>layout should not display "All languages" when only default language exists added
#10

Updated by Oliver Bartsch 22 days ago

  • Related to Bug #95387: Page module shows wrong "All languages" option in "columns" mode added

Also available in: Atom PDF