Bug #92553

Redirects Module with domains for each language

Added by Markus Gehrig 11 months ago. Updated 9 months ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2020-10-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hey there

We have a system which has a separate domain for each language.

  • DE => german_domain.ch
  • FR => french_domain.ch
  • EN => englisch_domain.ch

Most of the time this works great in most circumstances, but when it comes to the redirects things are not working as they should. At the moment we can't redirect a url with a foreign language.

french_domain.ch/test leads to the site in the default language, but not to the page in French as we would expect it.


Related issues

Related to TYPO3 Core - Feature #93162: Allow Redirects to translated pagesNew2020-12-22

Actions
#1

Updated by Riccardo De Contardi 10 months ago

  • Category set to Link Handling, Site Handling & Routing
#2

Updated by Guido Schmechel 9 months ago

Hi, how have you configured the redirects?

I have set the following for testing:
- I have configured two domains in ddev
- Page A (source) is a simple redirect to Page B (target)
- Page A (source) mapped to my danish domain
- Page B is a redirect in this form: "t3://page?uid=1 - - - &L=1"

In order for L=1 to be used, I have to switch on the option "Keep GET Parameters".

After that, the redirect ran successfully. Does that help you?

I admit: rather suboptimal from a UX point of view, but you get there. Perhaps more detailed documentation would help here?

#3

Updated by Guido Schmechel 9 months ago

  • Related to Feature #93162: Allow Redirects to translated pages added

Also available in: Atom PDF