Bug #92753

Enforce Composer 2 usage for TYPO3 development

Added by Helmut Hummel 4 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2020-11-02
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Composer 2 comes with a ton of benefits.
One of them is more predictable and cleaner updates, e.g. removing stale not required packages
or not taking installed state into account, resulting in better reproducible composer.lock files.

Since Composer 2 stable is released now, we should enforce it for TYPO3 development of all maintained branches.

Also available in: Atom PDF