Bug #92925

Limit to language is broken in TYPO3 10

Added by Alex Kellner 7 months ago. Updated 4 months ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2020-11-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

There are some problems in the page module with user groups that are only allowed to edit the additional languages (limit to language). Behavior was simulated on an empty TYPO3 10.4.10 instance.

Structure of the user groups (Screen 0):
Author 1 - may only edit Default (EN)
Author 2 - may only edit the additional language (DE)

The behavior of author 1 is correct, he may only edit the default language.

But there are some problems with author 2, which only appear in the page module - the list module seems to work correctly.
1. he is allowed to edit the content correctly (if you click on the icon in front), but the icons in the back are missing on the CE itself. (Screen 1)
2. in Free Mode the + icons for creating new content elements are missing. (Screen 1)
3. if the additional language is still empty, the + icons and the Translation Wizard are also missing (Screen 2)
4. and last the drop-down "Create new translation of this page" is missing for a page that has not yet been translated (Screen 3)

Greetings, Alex


Files

0_UsergroupSetup.png (82.7 KB) 0_UsergroupSetup.png Alex Kellner, 2020-11-24 16:43
1_IconsMissing.png (91.2 KB) 1_IconsMissing.png Alex Kellner, 2020-11-24 16:43
2_TranslationWizardMissing.png (47.9 KB) 2_TranslationWizardMissing.png Alex Kellner, 2020-11-24 16:43
3_NewPageTranslation.png (50.6 KB) 3_NewPageTranslation.png Alex Kellner, 2020-11-24 16:43
#1

Updated by Alex Kellner 7 months ago

Georg just asked me about the feature toggles.

We checked it and for whatever reason "Fluid based Page Module" was turned on, on our new installation (shouldn't this be turned off per default?). So everything that was described above is related to a turned on "Fluid based Page Module".


We also tested with turned off "Fluid based Page Module". Here the problems are a bit different then above mentioned:
1. Icons are shown correctly (no problem there)
2. + icons are also there (no problem there)
3. + icons are also there but the Translation Wizard is still missing
4. the drop-down "Create new translation of this page" is still missing

#2

Updated by Ingo Fabbri 5 months ago

Alex Kellner wrote in #note-1:

Georg just asked me about the feature toggles.

We checked it and for whatever reason "Fluid based Page Module" was turned on, on our new installation (shouldn't this be turned off per default?). So everything that was described above is related to a turned on "Fluid based Page Module".


We also tested with turned off "Fluid based Page Module". Here the problems are a bit different then above mentioned:
1. Icons are shown correctly (no problem there)
2. + icons are also there (no problem there)
3. + icons are also there but the Translation Wizard is still missing
4. the drop-down "Create new translation of this page" is still missing

Can confirm. With turned off fluid-page-module it gets a bit better. But the bugs that are unrelated to FPM still apply. Mostly the missing ability to

- edit page properties
- create page translation
- create content transation

is a show-stopper.

#3

Updated by Riccardo De Contardi 5 months ago

Is this one related? #91900

#4

Updated by Ingo Fabbri 4 months ago

Riccardo De Contardi wrote in #note-3:

Is this one related? #91900

In the first place the issues here are all about the interface. Foremost missing buttons. In #91900 it is about some trouble with DataHandler I assume. There may be some relation - just can't see one at the moment.

Also available in: Atom PDF