Bug #93122

Epic #93119: Bootstrap v5 migration

Default badge has no background color anymore

Added by Oliver Bartsch 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2020-12-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If using .badge without defining the background color with bg- (see: https://getbootstrap.com/docs/5.0/components/badge/), the badge has no background color anymore. This currently just works because for non "default" badges (e.g. badge-danger) because TYPO3 defines a custom background for these classes in Build/Sources/Sass/typo3/_element_badges.scss. So either add the "default" case here or directly switch to use the bg- classes through the core.

See e.g. the open documents badge in the toolbar:

<=>


Files

before.png (1.29 KB) before.png Oliver Bartsch, 2020-12-20 13:56
after.png (1.24 KB) after.png Oliver Bartsch, 2020-12-20 13:56

Related issues

Related to TYPO3 Core - Bug #93303: Incosistent badges in toolbar itemsClosedBenni Mack2021-01-17

Actions
#1

Updated by Oliver Bartsch 5 months ago

  • Has duplicate Bug #93303: Incosistent badges in toolbar items added
#2

Updated by Oliver Bartsch 5 months ago

  • Has duplicate deleted (Bug #93303: Incosistent badges in toolbar items)
#3

Updated by Oliver Bartsch 5 months ago

  • Related to Bug #93303: Incosistent badges in toolbar items added
#4

Updated by Riccardo De Contardi 5 months ago

  • Status changed from New to Closed

I close this issue in favor of #93303 (which has a patch) ,please continue the discussion there and test the patch. Thank you and thanks to @Oliver Bartsch that found this.

Also available in: Atom PDF