Bug #93127

Backend session not initialized but accessed on CLI

Added by Helmut Hummel 9 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2020-12-20
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Refactored session handling introduced a new property,
which is initialized when method "start" is called.

Since "start" is overridden in CliBackendUserAuthentication, the property
is never initialized, but accessed, once a log entry is written calling the "writeLog"
method, leading to a fatal error.


Related issues

Related to TYPO3 Core - Bug #93023: Rework session handlingClosed2020-12-07

Actions

Also available in: Atom PDF