Project

General

Profile

Actions

Bug #93282

closed

TYPO3 Exception #1478105826 when editing backend user group

Added by Michael Hank about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2021-01-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

We ran into a strange issue in an web that has been upgraded from 8.7 LTS to 10.4 LTS.

When trying to edit a backend user group via "Backend Users" > "Backend user groups" we get the following exception:

Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1478105826: Data structure file could not be resolved to an existing file | RuntimeException thrown in file /www/htdocs/w0182dcd/typo3_src-10.4.12/typo3/sysext/core/Classes/Configuration/FlexForm/FlexFormTools.php in line 688. Requested URL: https://www.{tld}/typo3/index.php?route=%%2Frecord%%2Fedit&token=--AnonymizedToken--&edit%%5Bbe_groups%%5D%%5B1%%5D=edit&returnUrl=%%2Ftypo3%%2Findex.php%%3Froute%%3D%%252Fmodule%%252Fsystem%%252FBeuserTxBeuser%%26token%%3D7c4fa7499c1e9b616e8d6c7016726924cda762cf%%26tx_beuser_system_beusertxbeuser%%255Baction%%255D%%3Dindex%%26tx_beuser_system_beusertxbeuser%%255Bcontroller%%255D%%3DBackendUserGroup

When trying to edit a backend user group via "List" > root page, we get a a slightly different exception.

Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1478105826: Data structure file could not be resolved to an existing file | RuntimeException thrown in file /www/htdocs/w0182dcd/typo3_src-10.4.12/typo3/sysext/core/Classes/Configuration/FlexForm/FlexFormTools.php in line 688. Requested URL: https://www.{tld}/typo3/index.php?route=%%2Frecord%%2Fedit&token=--AnonymizedToken--&edit[be_groups][1]=edit&returnUrl=%%2Ftypo3%%2Findex.php%%3Froute%%3D%%252Fmodule%%252Fweb%%252Flist%%26token%%3D3f3ca974b9f9dd580196ba041d9a91e5df3d912d%%26id%%3D0

I've removed the domain in the URLs and replaced it by the segment {tld} instead.

Actions #1

Updated by Georg Ringer about 3 years ago

  • Status changed from New to Needs Feedback

thanks for creating the issue. could you add some more stacktrace? this would be very helpful to reproduce it. or can you share some usergroup database export?

feel free to contact me on slack or mail if you don't want to add it here!

Actions #2

Updated by Michael Hank about 3 years ago

Georg Ringer wrote in #note-1:

thanks for creating the issue. could you add some more stacktrace? this would be very helpful to reproduce it. or can you share some usergroup database export?

feel free to contact me on slack or mail if you don't want to add it here!

Thank you for the reply. Unfortunately, I have no idea when this error occured and what has lead to this issue. It might has happend when upgrading from 8.7 LTS to 10.4 LTS, but I'm not quite sure.

Here's the usergroup database export, I don't think there's any private data included.

--
-- Tabellenstruktur für Tabelle `be_groups`
--

CREATE TABLE `be_groups` (
  `uid` int(10) UNSIGNED NOT NULL,
  `pid` int(10) UNSIGNED NOT NULL DEFAULT '0',
  `tstamp` int(10) UNSIGNED NOT NULL DEFAULT '0',
  `title` varchar(50) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
  `non_exclude_fields` text COLLATE utf8_unicode_ci,
  `explicit_allowdeny` text COLLATE utf8_unicode_ci,
  `allowed_languages` varchar(255) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
  `custom_options` text COLLATE utf8_unicode_ci,
  `db_mountpoints` text COLLATE utf8_unicode_ci,
  `pagetypes_select` text COLLATE utf8_unicode_ci,
  `tables_select` text COLLATE utf8_unicode_ci,
  `tables_modify` text COLLATE utf8_unicode_ci,
  `crdate` int(10) UNSIGNED NOT NULL DEFAULT '0',
  `cruser_id` int(10) UNSIGNED NOT NULL DEFAULT '0',
  `groupMods` text COLLATE utf8_unicode_ci,
  `file_mountpoints` text COLLATE utf8_unicode_ci,
  `file_permissions` text COLLATE utf8_unicode_ci,
  `hidden` smallint(5) UNSIGNED NOT NULL DEFAULT '0',
  `description` text COLLATE utf8_unicode_ci,
  `lockToDomain` varchar(50) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
  `deleted` smallint(5) UNSIGNED NOT NULL DEFAULT '0',
  `TSconfig` text COLLATE utf8_unicode_ci,
  `subgroup` text COLLATE utf8_unicode_ci,
  `workspace_perms` smallint(6) NOT NULL DEFAULT '1',
  `category_perms` text COLLATE utf8_unicode_ci,
  `availableWidgets` text COLLATE utf8_unicode_ci
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;

--
-- Daten für Tabelle `be_groups`
--

INSERT INTO `be_groups` (`uid`, `pid`, `tstamp`, `title`, `non_exclude_fields`, `explicit_allowdeny`, `allowed_languages`, `custom_options`, `db_mountpoints`, `pagetypes_select`, `tables_select`, `tables_modify`, `crdate`, `cruser_id`, `groupMods`, `file_mountpoints`, `file_permissions`, `hidden`, `description`, `lockToDomain`, `deleted`, `TSconfig`, `subgroup`, `workspace_perms`, `category_perms`, `availableWidgets`) VALUES
(1, 0, 1531922360, 'Redaktion', 'sys_file_reference:alternative,sys_file_reference:description,sys_file_reference:crop,sys_file_reference:link,sys_file_reference:title,pages:description,pages:nav_hide,pages:nav_title,pages:hidden,pages:starttime,pages:keywords,pages:abstract,pages:endtime,pages:doktype,pages:subtitle,pages:shortcut_mode,pages:fe_group,tt_content:pages,tt_content:date,tt_content:layout,tt_content:header_link,tt_content:imageorient,tt_content:starttime,tt_content:endtime,tt_content:header_layout,tt_content:hidden,tt_content:fe_group', 'tt_content:CType:header:ALLOW,tt_content:CType:text:ALLOW,tt_content:CType:textmedia:ALLOW,tt_content:CType:menu_subpages:ALLOW,tt_content:CType:form_formframework:ALLOW', '', NULL, '1', '1,4,3,254', 'pages,sys_file,sys_file_reference,fe_groups,fe_users,tt_content', 'pages,sys_file,sys_file_reference,fe_groups,fe_users,tt_content', 1528374962, 1, 'web_layout,web_ViewpageView,web_list,web_FormFormbuilder,file_FilelistList,user_setup,help_DocumentationDocumentation,help_AboutAbout', '1,2', 'readFolder,writeFolder,addFolder,renameFolder,moveFolder,deleteFolder,readFile,writeFile,addFile,renameFile,replaceFile,moveFile,copyFile,deleteFile', 0, '', '', 0, '', '', 0, '', NULL);
Actions #3

Updated by Georg Ringer almost 3 years ago

sorry I can't reproduce that with this sql. can you reproduce that with a clean installation? otherwise maybe it is possible to get access to your environment? you can contact me via email or slack if intersted on that

Actions #4

Updated by Christian Kuhn over 2 years ago

  • Status changed from Needs Feedback to Closed

I'd strongly suspect this is triggered by some faulty extension: core be_groups has no flex form fields that may need to be parsed, this code part shouldn't be triggered natively.

I guess this has been resolved meanwhile: If this happened during upgrade process, the extension either vanished meanwhile or has been updated.

We probably can't do much at the moment here.

If this issue persists, please re-open the issue or create a new one including some more data points.

Actions #5

Updated by David Bruchmann over 2 years ago

I had a resembling case after update and the reason was indeed an extension, but not faulty, just missing only.
After installing the extension everything was fine again.

Actions

Also available in: Atom PDF