Project

General

Profile

Actions

Bug #93329

closed

Fresh install not working

Added by Can Karadag over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2021-01-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Today I wanted to install a fresh typo3 system over composer, I setting up the system over the backend installer, after I set up the account settings a error was thrown when it was trying to create all the tables

I got following error:

Database query failed!
Query: CREATE TABLE `fe_sessions` (`ses_id` VARCHAR(255) DEFAULT '' NOT NULL, `ses_iplock` VARCHAR(39) DEFAULT '' NOT NULL, `ses_userid` INT UNSIGNED DEFAULT 0 NOT NULL, `ses_tstamp` INT UNSIGNED DEFAULT 0 NOT NULL, `ses_data` MEDIUMBLOB DEFAULT NULL, `ses_permanent` SMALLINT UNSIGNED DEFAULT 0 NOT NULL, `ses_anonymous` SMALLINT UNSIGNED DEFAULT 0 NOT NULL, INDEX `ses_tstamp` (ses_tstamp), PRIMARY KEY(ses_id)) DEFAULT CHARACTER SET utf8mb4 COLLATE `utf8mb4_unicode_ci` ENGINE = InnoDB Error: Specified key was too long; max key length is 767 bytes

i was trying to install TYPO3 10.4.12 I think this error happends because `ses_id` VARCHAR was changed from `ses_id` VARCHAR also the table be_sessions throws this type of error


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #93326: Error while Auto-Update: Error: Index column size too largeClosedStefan Froemken2021-01-20

Actions
Related to TYPO3 Core - Task #93131: Increase session id db field sizeClosed2020-12-21

Actions
Actions #1

Updated by Steffen Mächtel over 3 years ago

Can Karadag wrote:

Today I wanted to install a fresh typo3 system over composer, I setting up the system over the backend installer, after I set up the account settings a error was thrown when it was trying to create all the tables

I got following error:
[...]

i was trying to install TYPO3 10.4.12 I think this error happends because `ses_id` VARCHAR was changed from `ses_id` VARCHAR also the table be_sessions throws this type of error

I can confirm that issue after upgrading from 10.4.10 to 10.4.12. My database is utf8mb4_unicode_ci. The problem does not occur with utf8_unicode_ci (without mb4).

utf8_unicode_ci = 3 Bytes per character as primary key
utf8mb4_unicode_ci = 4 Bytes per character as primary key

Varchar(255) * 3 Bytes = 765 (works)
Varchar(255) * 4 Bytes = 1020 (Error: Specified key was too long; max key length is 767 bytes)

Actions #2

Updated by Steffen Mächtel over 3 years ago

  • Related to Bug #93326: Error while Auto-Update: Error: Index column size too large added
Actions #3

Updated by Benni Mack over 2 years ago

  • Status changed from New to Needs Feedback

Hey,

thanks for the feedback. Does this issue still occur with the latest v10.4.21 or v11.5.2?

Actions #4

Updated by Christian Kuhn over 2 years ago

  • Related to Task #93131: Increase session id db field size added
Actions #5

Updated by Christian Kuhn over 2 years ago

  • Status changed from Needs Feedback to Closed

fixed with #93131

Actions

Also available in: Atom PDF