Bug #93418

Unable to change page slug into a workspace, after page move.

Added by Gianluca Strafella 6 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2021-02-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.2
Tags:
workspaces,slug,redirects,url
Complexity:
Is Regression:
Sprint Focus:

Description

Hello,
with these preconditions:
  • installation with multiples workspaces (but also only one)
  • core extension "redirects" installed (10.4.12)
  • With this pages tree:

Tree at step 1

Test 
    |_sub page 1
      |__page_1
         |_page_1_1
         |_page_1_2 
      |__page_2
         |_page_2_1
         |_page_2_2

Step 1
In a workspace, we move the page_1_2 from "page_1" under the page "page_2".
After this step, the moved page is ok in backend and in frontend.

Tree after move

The page has still reached with this url:
http://typo310demo.local/test/sub-page-1/page-1/page-1-1

Step 2
We edit the page moved, and click on "Recalculate URL segment from page title" button. The slug changes properly and we see the message:
This page will be reachable via http://typo310demo.local/test/sub-page-1/page-2/page-1-1

We save the page. After save we see the message:
Slugs updated
Because you renamed a slug, the slugs of all sub-pages were updated for you automatically.

Step 3
Now,if we select with the "Page" module the page moved "page_1_2", the page appears ok on frontend.

BUT
if we click on the frontend menu, on the page moved, we see this error:
The page did not exist or was inaccessible. Reason: ID was not an accessible page

Same thing if we preview the new parent page "http://typo310demo.local/test/sub-page-1/page-2". We see the menu, but if when we click and on the entry "page_1_1", we see same error.

This problem causes that a backend operator cannot preview properly the tree after moving, and cannot show the moved page.

Thank you


Files

live-step-1.png (4.49 KB) live-step-1.png Tree at step 1 Gianluca Strafella, 2021-02-03 11:07
step-2.png (5.12 KB) step-2.png Tree after move Gianluca Strafella, 2021-02-03 11:14
#1

Updated by Benni Mack 3 months ago

  • Status changed from New to Closed

This change is fixed in TYPO3 v10.4 LTS

Also available in: Atom PDF