Bug #93501

FileDump return an image instead of pdf

Added by Maxime Lafontaine 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2021-02-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Hi.

I'm migrating an old site to TYPO3 v10 (from v7) and I have the fileadmin as not accessible publicly. That create the links to files as /index.php?eID=dumpFile&t=f&f=18151&token=***.

It was working fine before. A link to a pdf would show the pdf.
In v10 the working of the class has change. The file is proccess to resize or crop. So it can only return image...

https://github.com/TYPO3/TYPO3.CMS/blame/10.4/typo3/sysext/core/Classes/Controller/FileDumpController.php#L112

It probably correct in some case, but it do no work in this (link in the rte to a pdf file in a non-public File Storage).

Maybe it should validate if it is an image or not before process it? I'm not sure of the solution, but this is a problem.

Thanks.


Related issues

Related to TYPO3 Core - Bug #93024: PDF download from private storage yields thumbnailClosed2020-12-08

Actions
Related to TYPO3 Core - Feature #90068: Implement better FileDumpControllerClosedStefan Froemken2020-01-08

Actions
#1

Updated by Maxime Lafontaine 5 months ago

  • Is Regression set to Yes
#2

Updated by Georg Ringer 5 months ago

  • Related to Bug #93024: PDF download from private storage yields thumbnail added
#3

Updated by Georg Ringer 5 months ago

  • Related to Feature #90068: Implement better FileDumpController added
#4

Updated by Georg Ringer 5 months ago

  • Status changed from New to Closed

thanks for creating the issue. I am closing it as it is a duplicate of #93024. a patch is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67333

Also available in: Atom PDF