Project

General

Profile

Actions

Feature #90068

closed

Implement better FileDumpController

Added by Stefan Froemken over 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Category:
Image Generation / GIFBUILDER
Start date:
2020-01-08
Due date:
% Done:

100%

Estimated time:
PHP Version:
7.3
Tags:
Complexity:
easy
Sprint Focus:

Description

Hello,

I miss some options in FileDumpController like fetching sys_file_references, setting width/height or applying cropVariants.

Stefan


Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Bug #93024: PDF download from private storage yields thumbnailClosed2020-12-08

Actions
Related to TYPO3 Core - Bug #93410: The download of pdf files via privatestorage/eID returns an imageClosed2021-02-02

Actions
Related to TYPO3 Core - Bug #93501: FileDump return an image instead of pdfClosed2021-02-12

Actions
Actions #1

Updated by Georg Ringer over 4 years ago

  • Target version changed from next-patchlevel to Candidate for Major Version
Actions #2

Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62831

Actions #3

Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62834

Actions #4

Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62834

Actions #5

Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62834

Actions #6

Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62834

Actions #7

Updated by Gerrit Code Review over 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62834

Actions #8

Updated by Gerrit Code Review over 4 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62834

Actions #9

Updated by Gerrit Code Review over 4 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62834

Actions #10

Updated by Gerrit Code Review about 4 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62834

Actions #11

Updated by Gerrit Code Review about 4 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62834

Actions #12

Updated by Gerrit Code Review about 4 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62834

Actions #13

Updated by Stefan Froemken about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #14

Updated by Benni Mack about 4 years ago

  • Status changed from Resolved to Closed
Actions #15

Updated by Sebastian Michaelsen over 3 years ago

  • Related to Bug #93024: PDF download from private storage yields thumbnail added
Actions #16

Updated by Altan Tosun over 3 years ago

  • Related to Bug #93410: The download of pdf files via privatestorage/eID returns an image added
Actions #17

Updated by Altan Tosun over 3 years ago

  • Status changed from Closed to New

This change breaks eID file download – see: https://forge.typo3.org/issues/93410?next_issue_id=93409

First of all, all files are being processed. For example PDF's are not downadable anymore, instead you get an image. High-resolution images are also processed which is not intended. Cropping must be all the time explicit and choosable. We should not have any magic functions which does unexpected behaviour.

Actions #18

Updated by Georg Ringer about 3 years ago

  • Related to Bug #93501: FileDump return an image instead of pdf added
Actions #19

Updated by Georg Ringer about 3 years ago

  • Status changed from New to Closed

issue is closed and should be closed, please always create new issues.

Actions

Also available in: Atom PDF