Project

General

Profile

Actions

Bug #93667

closed

Disable logging of invalid requests due to manipulated form submissions

Added by Torben Hansen almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2021-03-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When a HMAC of a form submission has been manipulated, TYPO3 currently logs the resulting BadRequestException to sys_log and system logfiles. Since those log entries are typically generated by spambots, TYPO3 should not log those exceptions in order to keep the logs clean from client generated invalid request entries.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Feature #90134: Send 400 - BAD REQUEST on invalid hmacs from extbase formsClosed2020-01-16

Actions
Related to TYPO3 Core - Bug #87917: Bot manipulated form fields lead to exceptionRejected2019-03-14

Actions
Actions #1

Updated by Torben Hansen almost 3 years ago

  • Related to Feature #90134: Send 400 - BAD REQUEST on invalid hmacs from extbase forms added
Actions #2

Updated by Torben Hansen almost 3 years ago

  • Related to Bug #87917: Bot manipulated form fields lead to exception added
Actions #3

Updated by Gerrit Code Review almost 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68196

Actions #4

Updated by Torben Hansen almost 3 years ago

  • Subject changed from Disable logging of requests due to manipulated form submissions to Disable logging of invalid requests due to manipulated form submissions
Actions #5

Updated by Gerrit Code Review almost 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68196

Actions #6

Updated by Gerrit Code Review almost 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68196

Actions #7

Updated by Gerrit Code Review almost 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68196

Actions #8

Updated by Gerrit Code Review almost 3 years ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68732

Actions #9

Updated by Torben Hansen almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #10

Updated by Gerrit Code Review almost 3 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68857

Actions #11

Updated by Torben Hansen almost 3 years ago

  • Status changed from Under Review to Resolved
Actions #12

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF