Feature #93747

Exclude from speaking URL for new TYPO3 routing

Added by Bernhard Eckl 6 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2021-03-15
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

Hello,

realurl had a feature called „Exclude from speaking URL“ in page properties. How about integrating that into the core for the new routing?

#1

Updated by Martin Kutschker 6 months ago

I don't know the exact reason was but that has been left for extensions to implement. You can install "masi" for your use case.

#2

Updated by Bernhard Eckl 6 months ago

Thank you for your hint, I will try the extension.

#3

Updated by Benni Mack about 2 months ago

  • Status changed from New to Closed

Just for the sake of completeness:

The feature was left-out by design to keep "configuration" to a minimum. Mainly because "exclude_from_speaking_url" had several drawbacks in RealURLs implementation back then which could only be mitigated by workarounds (e.g. that's one of the reasons Core v9 ships with more than just "URL parts" but full URLs after the base).

TYPO3 Core Routing was built to allow such features as extensions for specific use-cases, such as masi https://extensions.typo3.org/extension/masi

Also available in: Atom PDF