Bug #93757

Topbar links such as user settings do not work after the topbar was refreshed

Added by Oliver Bartsch about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2021-03-16
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Whenever a topbar refresh is triggered, e.g. by activating/deactivating of an extension in the extension manager, or when changing the backend users language, the topbar links such as "user settings" do not work anymore. Only a refresh of the whole TYPO3 installation "fixes" the issue.

It seems like this got introduced with #92704.


Related issues

Related to TYPO3 Core - Feature #92704: Make the navigation through module menu more efficient for keyboard usersClosed2020-10-25

Actions
#1

Updated by Oliver Bartsch about 2 months ago

  • Related to Feature #92704: Make the navigation through module menu more efficient for keyboard users added
#2

Updated by Gerrit Code Review about 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68495

#3

Updated by Gerrit Code Review about 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68495

#4

Updated by Gerrit Code Review about 2 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68495

#5

Updated by Benjamin Franzke about 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF