Bug #93856

First install wizard of TYPO3 11 broken

Added by Stefan Froemken 7 months ago. Updated 15 days ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2021-04-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello,

I have just installed TYPO3 11.1 in DDEV on my Mac.

ddev config --composer-version "2" --docroot "public" --php-version "7.4" --project-name "typo3111" --project-type "typo3" --timezone "Europe/Berlin" --create-docroot

ddev start

ddev composer create "typo3/cms-base-distribution:^11.1" . --prefer-dist

Install Wizard Step 1-4 no problem.

On last Wizard I have chosen "Take me straight to the backend" -> "Open the TYPO3 backend", but the green button does not work.

Request URL: https://typo3111.ddev.site/typo3/install.php
Request Method: POST
Status Code: 500 
Remote Address: 127.0.0.1:443
Referrer Policy: strict-origin-when-cross-origin

var/log/typo3_b87b33bac7.log

Fri, 02 Apr 2021 21:31:36 +0200 [CRITICAL] request="a8eb562161da0" component="TYPO3.CMS.Core.Error.DebugExceptionHandler": Core: Exception handler (WEB): Uncaught TYPO3 Exception: Return value of TYPO3\CMS\Core\Database\Connection::select() must implement interface Doctrine\DBAL\Driver\Statement, instance of Doctrine\DBAL\ForwardCompatibility\Result returned | TypeError thrown in file /var/www/html/public/typo3/sysext/core/Classes/Database/Connection.php in line 277. Requested URL: https://typo3111.ddev.site/typo3/install.php - {"TYPO3_MODE":"BE","exception":{}}

May be there is a Doctrine version miss-match...

Stefan

#1

Updated by Stefan Froemken 7 months ago

TYPO3 installs Doctrine 2.13:

➜  typo3_111 ddev composer show doctrine/dbal    
name     : doctrine/dbal
descrip. : Powerful PHP database abstraction layer (DBAL) with many features for database schema introspection and management.
keywords : abstraction, database, db2, dbal, mariadb, mssql, mysql, oci8, oracle, pdo, pgsql, postgresql, queryobject, sasql, sql, sqlanywhere, sqlite, sqlserver, sqlsrv
versions : * 2.13.0

This matches issue ticket on GitHub:

https://github.com/doctrine/dbal/issues/4572

#2

Updated by Stefan Froemken 7 months ago

Version of doctrine/dbal 2.13 was released just 3 days ago:
https://github.com/doctrine/dbal/releases/tag/2.13.0

Don't know how we should solve that. Prevent installing 2.13 or solve the problem in Queries of TYPO3 core?

#3

Updated by Riccardo De Contardi 7 months ago

related? #93848

#4

Updated by Stefan Froemken 7 months ago

Maybe. The related patch was merged for the unreleased version 11.2 (master) and 10.4. But I have the issue in current TYPO3 11.1.1.

#5

Updated by Benni Mack 4 months ago

  • Status changed from New to Needs Feedback

Can you check the latest dev-master (upcoming 11.3) - we've integrated a few Doctrine-related fixes there due to their new version.

#6

Updated by Stefan Froemken 15 days ago

  • Status changed from Needs Feedback to Closed

IMO this problem was solved with 2.13.2 or 2.13.3. Currently I can not reproduce it anymore.

Also available in: Atom PDF