Project

General

Profile

Actions

Bug #93920

closed

First language of config.yaml is used as Default FE language even when it is disabled

Added by Jo Hasenau almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Localization
Target version:
Start date:
2021-04-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

We've got the following Szenario:

Default language for a multi-language, multi-domain project is German.

So each of the different site configurations of that project got a language configuration for language ID 0 having a path "/de/" in the first place.

Now we added the other languages for each domain i.e. FR and IT for Switzerland, which is working fine, because each of the languages needs to be visible in the frontend, including German.

Now we added FR for France and since there should be no visible German language in the frontend, we set the default language to "enabled: false".

As expected this removes the frontend visibility of German pages but: The redirect to the German path stays active .

So when you hit the domain without a language suffix, the redirect will point to "/de/" and of course this will throw an error because the page is not configured.

Moving the default language to the end of the list did not work in the Backend module, but it was possible to do it in the YAML file, and after moving the entry the redirect worked fine. So the redirect seems to consider the first entry in the list regardless of the "enabled" state.

IMHO automatic redirects must ignore entries that are disabled, so that the first visible entry will be the redirect default target .

Actions #1

Updated by Jo Hasenau almost 3 years ago

  • Description updated (diff)
Actions #2

Updated by Gerrit Code Review almost 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68775

Actions #3

Updated by Gerrit Code Review almost 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68775

Actions #4

Updated by Gerrit Code Review almost 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68775

Actions #5

Updated by Gerrit Code Review almost 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68775

Actions #6

Updated by Gerrit Code Review almost 3 years ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68818

Actions #7

Updated by Benni Mack almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #8

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF