Project

General

Profile

Actions

Bug #94030

closed

Second translation is not shown in BE in Fluid Based Page module

Added by Christian Welzel about 3 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The new page module does not show more than two languages (original and first translation) because of overwriting the {item} variable in EXT:backend/Resources/Private/Partials/PageLayout/LanguageColumns.html

Perhaps this works if the second translation is based on the first one, but in my case both translations are based on the source language. In this case {item.translations.{languageId}} in line 87 is empty and the content of the second translation doesnt get rendered. This is because {item} in this line is not the source item, but the item if the first translation! This happens because {item} gets overwritten in line 88 and is not reset at the beginning of the <f:for> loop.

Quick fix, that works for me:

&lt;f:for each=&quot;{column.items}&quot; as=&quot;item&quot; iteration=&quot;itemIterator&quot;&gt;
&lt;f:variable name=&quot;real_item&quot; value=&quot;{item}&quot;/&gt;
&lt;tr&gt;
&lt;td class=&quot;t3-grid-cell&quot; data-colpos=&quot;{column.columnNumber}&quot;&gt;
&lt;f:render partial=&quot;PageLayout/Record&quot; arguments=&quot;{_all}&quot; /&gt;
&lt;/td&gt;
&lt;f:for each=&quot;{languageColumns}&quot; as=&quot;languageColumn&quot;&gt;
&lt;f:variable name=&quot;item&quot; value=&quot;{real_item}&quot;/&gt;

Files

cattura4.png (113 KB) cattura4.png Riccardo De Contardi, 2022-08-04 13:27
cattura5.png (107 KB) cattura5.png Riccardo De Contardi, 2022-08-04 13:34
Actions #1

Updated by Oliver Bartsch over 2 years ago

  • Status changed from New to Needs Feedback

Hi, thanks for reporting. There had been a few patches in this area in the last couple of months (e.g. #94047). Could you therefore please check, if this issue is still reproducible in v11?

Updated by Riccardo De Contardi almost 2 years ago

Maybe it has been solved also for version 10.x?

I performed the following test on version 10.4.31 with "Fluid based page module" enabled and three languages:
English(Default), French, Deutsch

Example 1

the content element pointed out has been translated from the "French" Column

Example 2

the content element pointed out has been translated from the "English" Column

Am I missing something? Or a different test is required?

Actions #3

Updated by Oliver Bartsch 10 months ago

  • Status changed from Needs Feedback to Closed

I'm closing this no, because this has been fixed in the meantime. In case you still encounter similar issues, please get in contact with me or create a new issue with reference to this one.

Best, Oli

Actions

Also available in: Atom PDF