Bug #94056

Task #86141: Remove superfluous database contraint in DataMapProcessor

Selecting wrong translation while synchronizeInlineRelations

Added by Alexander Opitz 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Should have
Category:
DataHandler aka TCEmain
Start date:
2021-05-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In #80141 add allowLanguageSynchronization chain resolving the synchronization of languages was introduced, which have a small issue on InlineRelations, which leads to wrong content in translations inline relation.

The code in question is

TYPO3\CMS\Core\DataHandling\Localization\DataMapProcessor::resolveAncestorId()

if (
    !empty($fieldNames['source'])
    && $element[$fieldNames['source']] !== $element[$fieldNames['parent']]
) {
    return (int)$fieldNames['source'];
}

First, here we return the integer representation of the field name for the source field but we liked to return the ID which is inside the source field.
Second, we do not check if we return the integer 0, which may later select completely wrong records while synchronizeInlineRelations


Related issues

Related to TYPO3 Core - Bug #80141: Add allowLanguageSynchronization chain resolvingClosedOliver Hader2017-03-04

Actions
Is duplicate of TYPO3 Core - Bug #91430: Unrelated tt_content associated to a news after translating itClosed2020-05-18

Actions
#1

Updated by Alexander Opitz 6 months ago

  • Related to Bug #80141: Add allowLanguageSynchronization chain resolving added
#2

Updated by Alexander Opitz 6 months ago

  • Description updated (diff)
#3

Updated by Gerrit Code Review 6 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/69013

#4

Updated by Gerrit Code Review 6 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/69013

#5

Updated by Alexander Opitz 6 months ago

This seams duplicate of #91430

#6

Updated by Alexander Opitz 6 months ago

  • Is duplicate of Bug #91430: Unrelated tt_content associated to a news after translating it added
#7

Updated by Alexander Opitz 6 months ago

  • Status changed from Under Review to Resolved
#8

Updated by Oliver Hader 6 months ago

  • Parent task set to #86141
#9

Updated by Oliver Hader 6 months ago

  • Status changed from Resolved to Closed

→ see #86141

Also available in: Atom PDF