Bug #80141

Add allowLanguageSynchronization chain resolving

Added by Oliver Hader over 2 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Localization
Target version:
-
Start date:
2017-03-04
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Currently the localization behavior does not consider localization chains concerning field values to be synchronized over multiple localization hops that use the relative l10n_state "source".

Imagine the following scenario of content element:
  • [uid:10, sys_language_uid:0, l18n_parent:0, l10n_source:0, header:Value]
  • [uid:11, sys_language_uid:1, l18n_parent:10, l10n_source:10, header:Value, l10n_state:{header:parent}]
  • [uid:12, sys_language_uid:2, l18n_parent:10, l10n_source:11, header:Value, l10n_state:{header:source}]

Now if the record of the default record (uid:10) will be updated and the header value set to "Modified", only direct dependents would be synchronized. The automated update of the direct-child localization record (uid:11) does not trigger another update for the grand-child localization (uid:12). To achieve this, the data-map processor has been extended to collect new modifications to the data-map caused by synchronization processes - as long as modifications could be determined, another synchronization round is triggered for the modified items. This way the localization chain is completely synchronized if required, depending on the according l10n_state settings.


Related issues

Precedes TYPO3 Core - Bug #80944: Inline records are duplicated upon saving the master record Needs Feedback 2017-03-06

Associated revisions

Revision e7217da4 (diff)
Added by Oliver Hader over 2 years ago

[BUGFIX] Add allowLanguageSynchronization chain resolving

Currently the localization behavior does not consider localization
chains concerning field values to be synchronized over multiple
localization hops that use the relative l10n_state "source".

Imagine the following scenario of content elements:
  • { uid:10, sys_language_uid:0, l18n_parent:0, l10n_source:0,
    header:Value, l10n_state:null }
  • { uid:11, sys_language_uid:1, l18n_parent:10, l10n_source:10,
    header:Value, l10n_state:{header:parent} }
  • { uid:12, sys_language_uid:2, l18n_parent:10, l10n_source:11,
    header:Value, l10n_state:{header:source} }

Now if the record of the default language (uid:10) will be updated and
the header value set to "Modified", only direct dependents would be
synchronized. The automated update of the direct-child localization
record (uid:11) does not trigger another update for the grand-child
localization (uid:12).
To achieve this, the data-map processor has been extended to collect
new modifications to the data-map caused by synchronization processes
- as long as modifications could be determined, another synchronization
round is triggered for the modified items.
This way the localization chain is completely synchronized if required,
depending on the according l10n_state settings.

Change-Id: Ic08460f3ed0071f3dca6c6d1666031895bc3d832
Resolves: #80141
Releases: master
Reviewed-on: https://review.typo3.org/51952
Tested-by: TYPO3com <>
Tested-by: Susanne Moog <>
Reviewed-by: Susanne Moog <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Oliver Hader over 2 years ago

  • Category set to Localization

#2 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51952

#3 Updated by Gerrit Code Review over 2 years ago

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51952

#4 Updated by Gerrit Code Review over 2 years ago

Patch set 13 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51952

#5 Updated by Oliver Hader over 2 years ago

  • Description updated (diff)

#6 Updated by Gerrit Code Review over 2 years ago

Patch set 14 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51952

#7 Updated by Oliver Hader over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Xavier Perseguers over 2 years ago

  • Precedes Bug #80944: Inline records are duplicated upon saving the master record added

#9 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF