Bug #94113

Trusted SERVER_NAME check is broken when a HTTPS broker proxies requests to a HTTP backend

Added by Benjamin Franzke 4 months ago. Updated 15 days ago.

Status:
Closed
Priority:
Should have
Category:
System/Bootstrap/Configuration
Target version:
Start date:
2021-05-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Scenario: * Proxy Server HTTPS (SSL termination) => Port 443 * Application Server HTTP => Port 80 * Default trustedHostsPattern configuration (GeneralUtility::ENV_TRUSTED_HOSTS_PATTERN_SERVER_NAME)

https://mydomain.com (e.g. via nginx server) -> proxied to apache backend -> http://10.0.0.1/

Proxy configuration like:

location / {
    proxy_set_header Host $host;
    proxy_set_header X-Real-IP $remote_addr;
    proxy_pass http://10.0.0.1;
}

Because of the HOST_NAME verification that consideres the proxy port is equal to the local webserver port, such configurations currently need to configure a slow custom trustedHostsPattern, although 'mydomain.com' is the correct SERVER_NAME.

#1

Updated by Gerrit Code Review 4 months ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66613

#2

Updated by Gerrit Code Review 4 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66613

#3

Updated by Gerrit Code Review 4 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66613

#4

Updated by Gerrit Code Review 4 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/69192

#5

Updated by Benjamin Franzke 4 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Benni Mack 15 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF