Bug #94144

Return values of FileReferences getters is null when it should be empty string

Added by Chris Müller 4 months ago. Updated about 2 months ago.

Status:
Under Review
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2021-05-17
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In introduced in a project Rector with the code quality rule. In one of my controllers I have the following code:

/* @var FileReference $image */
if ($image->getAlternative()) {
    // do something
}

Rector now changes this condition to:

if ($image->getAlternative() !== '') {
   // do something
}

This is because the @return annotation of the getAlternative() method is set to "string".

But this is not correct as ->getAlternative() can also return null.

The same is with ->getTitle() and ->getDescription().

#1

Updated by Gerrit Code Review 4 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/69155

#2

Updated by Chris Müller 4 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#3

Updated by Gerrit Code Review about 2 months ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/70256

Also available in: Atom PDF