Project

General

Profile

Actions

Bug #94510

closed

SiteConfig with a config for a not available extension breaks errorHandling e. g. 404 page

Added by Christian Hackl over 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2021-07-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you have a siteconfig.yaml with e.g. a configuration for tt_address, BUT tt_address is not present in the TYPO3 system / tt_address is not installed and then try to call a non-existing page in the FE (e.g. "domain.tld/not_existing_page" you get the error message that the table tt_address does not exist.
This would be fine with "Debug"-Enabled and even desirable - but with Production/Live you should get the 404-page instead of the error message.

errorHandling:
  -
    errorCode: '404'
    errorHandler: Page
    errorContentSource: 't3://page?uid=30'
routeEnhancers:
  AddressPlugin:
    type: Extbase
    extension: TtAddress
    plugin: ListView
    routes:
      - routePath: '/{address_slug}'
        _controller: 'Address::show'
        _arguments:
          address_slug: address
    aspects:
      address_slug:
        type: PersistedAliasMapper
        tableName: tt_address
        routeFieldName: slug

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #94585: Siteconfig - 404 error not triggered if routeEnhancers is configuredClosed2021-07-19

Actions
Actions #1

Updated by Riccardo De Contardi over 1 year ago

  • Category set to Link Handling, Site Handling & Routing
Actions #2

Updated by Benni Mack over 1 year ago

  • Status changed from New to Needs Feedback

Hi Christian,

thanks for your feedback. I guess you get a SQL error, because the DB table "tt_address" does not exist? Can you share some more information?

Actions #3

Updated by Benni Mack about 1 year ago

  • Related to Bug #94585: Siteconfig - 404 error not triggered if routeEnhancers is configured added
Actions #4

Updated by Christian Kuhn 12 months ago

  • Status changed from Needs Feedback to Closed

hey. i'm going to close this due to lack of feedback for now and hope this is ok. please share more information on this in case the issue is still relevant.

Actions

Also available in: Atom PDF