Bug #94890

EXT:introduction installation: No soft reference parser found for "rtehtmlarea_images"

Added by Alexander Nitsche 2 months ago. Updated 15 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Start date:
2021-08-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When installing the TYPO3 distribution package EXT:introduction in a fresh TYPO3 master, the import of the page tree breaks at
https://github.com/TYPO3/typo3/blob/master/typo3/sysext/impexp/Classes/Import.php#L868
with this exception:

OutOfRangeException
No soft reference parser found for "rtehtmlarea_images".
1627899342
/var/www/html/public/typo3/sysext/core/Classes/DataHandling/SoftReference/SoftReferenceParserFactory.php
136

The installation worked fine yesterday, so any recent patch in TYPO3 Core or EXT:introduction / EXT:bootstrap_package could have cause this side-effect.


Related issues

Related to TYPO3 Core - Task #94687: Deprecate SoftReferenceIndexClosed2021-08-02

Actions
Related to TYPO3 Core - Bug #95012: Non existing softref parser keys throw exceptionsClosed2021-08-27

Actions
#1

Updated by Alexander Nitsche 2 months ago

Investigations by Nikita have revealed that the EXT:bootstrap_package configuration file
https://github.com/benjaminkott/bootstrap_package/blame/master/Configuration/TCA/Overrides/300_content_general_columns.php#L125
might be the problem as "rtehtmlarea_images" is not supported anymore since some time by TYPO3 and probably is more strict about it now.

#2

Updated by Oliver Hader 2 months ago

SoftReferenceParserFactory was introduced with https://review.typo3.org/c/Packages/TYPO3.CMS/+/70177

#3

Updated by Oliver Hader 2 months ago

  • Related to Task #94687: Deprecate SoftReferenceIndex added
#4

Updated by Lina Wolf 2 months ago

after the images in the rtehtmlarea got removed I get the next error, this time for field "image"

Sat, 14 Aug 2021 16:45:04 +0000 [WARNING] request="54e2a4bf2609e" component="TYPO3.CMS.Impexp.Utility.ImportExportUtility": No soft reference parser found for "images".
#5

Updated by Alexander Nitsche 2 months ago

No soft reference parser found for "images".

Has been solved in the EXT:bootstrap_package patch https://github.com/benjaminkott/bootstrap_package/pull/1046.

#6

Updated by Alexander Nitsche 2 months ago

This issue can be closed.

#7

Updated by Benni Mack about 2 months ago

  • Target version changed from 11.4 to 11 LTS
#8

Updated by Benni Mack 21 days ago

  • Target version changed from 11 LTS to Candidate for patchlevel
#9

Updated by Nikita Hovratov 20 days ago

  • Related to Bug #95012: Non existing softref parser keys throw exceptions added
#10

Updated by Nikita Hovratov 20 days ago

Fixed with #95012

#11

Updated by Benni Mack 15 days ago

  • Status changed from New to Closed

Also available in: Atom PDF