Bug #95404

No refindex entries generated for sys_language_uid anymore

Added by Nikita Hovratov 8 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2021-09-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Reproduction:
Create a translation of a page.
Check in the sys_refindex table for any entry with field = "sys_language_uid". There is none.

The reason for this is, the new TCA feature type="language".
The ReferenceIndex checked for type "select" before.


Related issues

Related to TYPO3 Core - Bug #93470: XML export data does not include page translations.Under Review2021-02-09

Actions
Related to TYPO3 Core - Bug #94616: Problems after t3d import (Extension impexp 10.4.17)Under Review2021-07-22

Actions
#1

Updated by Benni Mack 8 months ago

  • Status changed from New to Needs Feedback

Hey nikita,

yes. this is by design. By not refereing sys_language anymore, we don't need the refindex entries anymore as the IDs are now arbitrary numbers used by the site configuration. This way, we can slowly phase out sys_language DB table and move towards actual locales.

A nice side-effect: The refindex is much smaller now.

One of the reasons why the select was a bad solution was that sys_refindex did NOT contain any references to language=-1 or language=0.

Where do you have a problem with that approach?

#2

Updated by Nikita Hovratov 8 months ago

Hi Benni, thanks for the explanation!
The problem lies in the import / export module. It uses the reference index to detect relations of pages.
Translated pages were relations before the change and were added as such to the export file.
Now they are missing and page translations are not exported anymore.

See here: https://review.typo3.org/c/Packages/TYPO3.CMS/+/71374

#3

Updated by Christian Kuhn 6 months ago

ext:impexp has to follow here. we should finish your patch.

#4

Updated by Christian Kuhn 6 months ago

  • Related to Bug #93470: XML export data does not include page translations. added
#5

Updated by Christian Kuhn 6 months ago

  • Related to Bug #94616: Problems after t3d import (Extension impexp 10.4.17) added
#6

Updated by Christian Kuhn 6 months ago

should we close here and tackle the impexp issue in the related issues as your patch suggests already?

#7

Updated by Christian Kuhn 3 months ago

  • Status changed from Needs Feedback to Closed

Let's close here for now and continue in the other issues.

Also available in: Atom PDF