Bug #94616

Problems after t3d import (Extension impexp 10.4.17)

Added by Martina Ahlswede 10 months ago. Updated 6 months ago.

Status:
Under Review
Priority:
Should have
Assignee:
-
Category:
Import/Export (T3D)
Start date:
2021-07-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.2
Tags:
multilingual translation page xml t3d
Complexity:
Is Regression:
Sprint Focus:

Description

1. Wenn a translated page (with copy mode or translate mode) is exported and imported via t3d, the page translation is not included. Relevant report on XML exist already: [[https://forge.typo3.org/issues/93470]]

2. What else we would like to report is:
After the translated page has been created manually, all the translated content elements appear as it should, but the translation button appears also even though all content elements have been already translated. Cause: l10n_source during import was not changed appropriately.

The suitable state in the database:

The original Translated Page:

In the table pages:

In the table tt_content:

The Page imported via t3d:

In the table pages:

The translated page is missing.

In the table tt_content:

After manual translation of the page:

In the table pages:

In the table tt_content:

Now the translated page is there, all translated content elements appear and the translation button appears also.

Suggestion: As we understand it, after t3d import it should be like this:

In the table pages:

The translated page is included.

In the table tt_content:

Correct connection between the original and the translated content element on the new page has been created, so the translation button will not appear.


Files

table_pages1.png (12.5 KB) table_pages1.png Martina Ahlswede, 2021-07-22 12:01
table_tt_content1.png (13.9 KB) table_tt_content1.png Martina Ahlswede, 2021-07-22 12:01
table_pages2-import-via-t3d.png (11.7 KB) table_pages2-import-via-t3d.png Martina Ahlswede, 2021-07-22 12:04
table_ttcontent2-import-via-t3d.png (15.7 KB) table_ttcontent2-import-via-t3d.png Martina Ahlswede, 2021-07-22 12:06
table_pages3_manual_translation.png (12.5 KB) table_pages3_manual_translation.png Martina Ahlswede, 2021-07-22 12:08
table_ttcontent3_manual_translation.png (15.3 KB) table_ttcontent3_manual_translation.png Martina Ahlswede, 2021-07-22 12:11
table_pages4_suggestion.png (13.4 KB) table_pages4_suggestion.png Martina Ahlswede, 2021-07-22 12:12
table_ttcontent4_suggestion.png (15.7 KB) table_ttcontent4_suggestion.png Martina Ahlswede, 2021-07-22 12:28

Related issues

Related to TYPO3 Core - Bug #93470: XML export data does not include page translations.Under Review2021-02-09

Actions
Related to TYPO3 Core - Bug #95404: No refindex entries generated for sys_language_uid anymoreClosed2021-09-30

Actions
#1

Updated by Martina Ahlswede 10 months ago

  • Related to Bug #93470: XML export data does not include page translations. added
#2

Updated by Martina Ahlswede 10 months ago

  • PHP Version set to 7.2
#3

Updated by Martina Ahlswede 10 months ago

  • Subject changed from Problems after t3d import (Extension impexp 10.4.10) to Problems after t3d import (Extension impexp 10.4.17)

As addition to "After manual translation of the page":

Now the translated page is there, all translated content elements appear and the translation button appears also, because the connection between the original and the translated content element isn‘t correct.

(Although on the with translate mode translated Page don’t appear the translate button after t3d, but the connection between the original and the translated content element ist also not correct. If a new content element is added and translated, all content elements on this page are re-translated.

#4

Updated by Gerrit Code Review 8 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/71374

#5

Updated by Gerrit Code Review 8 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/71374

#6

Updated by Gerrit Code Review 8 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/71374

#7

Updated by Christian Kuhn 6 months ago

  • Related to Bug #95404: No refindex entries generated for sys_language_uid anymore added
#8

Updated by Gerrit Code Review 6 months ago

Patch set 4 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/71374

Also available in: Atom PDF