Bug #95488

Exception in FE and when filtering in redirects module if redirect target has wrong format

Added by Sybille Peters 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2021-10-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Versions

  • TYPO3 10.4.21

Reproduce

1. Enter a redirect with target with page link, formatted incorrectly:

page=uid=p1004

2. Load the page (= redirect source) in FE: exception

3. Filter by the source in the redirects module: exception

Exception

Wed, 06 Oct 2021 07:12:14 +0200 [CRITICAL] request="400a38d4d7411" component="TYPO3.CMS.Core.Error.ProductionExceptionHandler": 
Core: Exception handler (WEB): Uncaught TYPO3 Exception: 
#1460581769: LinkHandler for page=uid=p1004 was not registered | TYPO3\CMS\Core\LinkHandling\Exception\UnknownLinkHandlerException thrown in file
/var/www/mysite/releases/35/htdocs/typo3/sysext/core/Classes/LinkHandling/LinkService.php in line 117.
Requested URL: https://uol.de/****** - 
{"TYPO3_MODE":"FE","exception":"TYPO3\\CMS\\Core\\LinkHandling\\Exception\\UnknownLinkHandlerException: 
LinkHandler for page=uid=p1004 was not registered in 
/var/www/mysite/releases/35/htdocs/typo3/sysext/core/Classes/LinkHandling/LinkService.php:117

see file exception_issue_redirects.txt for full stack dump

Fix problem

Problem can be fixed, by fixing the wrong target. However, this is difficult to do in the redirects module (because of the exception when filtering). Can be fixed in DB directly:

UPDATE sys_redirect SET target='t3://page?uid=1004' WHERE target='t3://page=uid=p1004';

Related

See exception entry: https://github.com/TYPO3-Documentation/TYPO3CMS-Exceptions/pull/37/files


Files

exception_issue_redirects.txt (7.33 KB) exception_issue_redirects.txt Exception stack trace Sybille Peters, 2021-10-06 07:52
#2

Updated by Sybille Peters 4 months ago

  • Description updated (diff)
#3

Updated by Gerrit Code Review 4 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/71500

#4

Updated by Gerrit Code Review 4 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/71361

#5

Updated by Oliver Bartsch 4 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF