Bug #96449

Exception with Adminpanel activated

Added by Sybille Peters 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
AdminPanel
Target version:
-
Start date:
2022-01-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
12
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Can be reproduced with latest "main" branch (12-dev).

1/1) TypeError
TYPO3\CMS\Core\TimeTracker\TimeTracker::fixContent(): Argument #1 ($arr) must be of type array, null given, called in /var/www/html/typo3/sysext/core/Classes/TimeTracker/TimeTracker.php on line 328

in /var/www/html/typo3/sysext/core/Classes/TimeTracker/TimeTracker.php line 437
     * @param string $depthData Prefixed icons for new PM icons
     * @param string $vKey Seems to be the previous tsStackLog key
     * @return string Returns the $content string generated/modified. Also the $arr array is modified!
     */
    protected function fixContent(array &$arr, string $content, string $depthData = '', string $vKey = ''): string
    {
        $entriesCount = 0;
        $c = 0;
        // First, find number of entries

Reproduce

1. Created new installation following instructions https://docs.typo3.org/m/typo3/guide-contributionworkflow/main/en-us/Appendix/SettingUpTypo3Ddev.html (with PHP 8.0)
2. Created empty root page page with default TypoScript (Hello World)

# Default PAGE object:
page = PAGE
page.10 = TEXT
page.10.value = HELLO WORLD!

3. Enable adminpanel

config.admPanel = 1 

4. Load page in frontend

5. Activate adminpanel on bottom right

Exception occurs


Files

stacktrace_adminpanel.log (26.1 KB) stacktrace_adminpanel.log Sybille Peters, 2022-01-02 14:01
#1

Updated by Susanne Moog 5 months ago

  • Status changed from New to Resolved

This issue is a duplicate of #96448 - please test the patch attached there.

Also available in: Atom PDF