Project

General

Profile

Actions

Bug #97778

closed

contentsLangDirection is not set automatically for RTL languages

Added by Philipp Kitzberger about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2022-06-15
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When initializing CKEditor TYPO3 is generating a configuration array that contains contentsLanguage but not contentsLangDirection.

EXT:rte_ckeditor/Classes/Form/Element/RichTextElement.php:398

$configuration['contentsLanguage'] = $this->getLanguageIsoCodeOfContent();

For most languages that's OK but not for Arabic which is RTL and the editor should be set to that mode. Otherwise the user needs to apply the dir-attribute to each and every paragraph manually if they wanna edit the texts in the intended way.

A fix could be determining the direction based on reading the languages dir parameter from the site config? Or simply hardcoding a list of the most common RTL languages (Arabic, Hebrew, ...)

Actions #1

Updated by Georg Ringer about 2 years ago

  • Status changed from New to Accepted
  • Assignee set to Georg Ringer
Actions #2

Updated by Georg Ringer about 2 years ago

Thanks for creating this issue. The solution will be only accepted for 12 I guess, therefore I suggest to use the event AfterPrepareConfigurationForEditorEvent for changing the configuration in your project

Actions #3

Updated by Gerrit Code Review about 2 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/74966

Actions #4

Updated by Gerrit Code Review about 2 years ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/74966

Actions #5

Updated by Gerrit Code Review about 2 years ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/74966

Actions #6

Updated by Gerrit Code Review almost 2 years ago

Patch set 4 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/74966

Actions #7

Updated by Georg Ringer almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #8

Updated by Benni Mack almost 2 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF