Project

General

Profile

Actions

Bug #98222

closed

Inconsistent form rendering after #93887

Added by Elias Häußler almost 2 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2022-08-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
8.1
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The changed introduced with #93887 / #92406 introduced a change in behavior concerning form rendering after submit:

I noticed with EXT:form_consent, that the Render.html template is not rendered on form submit anymore. That’s probably because the controller’s perform action is now rendered cached and the FormRequestHandler – which is used as “replacement” – is only responsible for the <formvh:render> part in the template. Therefore, everything else in the template is not rendered anymore, especially the <f:flashMessages /> VH.

I noticed this when running tests for EXT:form_consent with TYPO3 11.5.15, see https://github.com/eliashaeussler/typo3-form-consent/runs/8011130200?check_suite_focus=true. Currently, because of that, EXT:form_consent can still not be used properly with TYPO3 >= 11.5.13 (Background: If there’s an error in the finisher of EXT:form_consent, a flash message is generated and finisher invocation is cancelled. Prior to the introduced change, the flash message was shown in FE, now it’s hidden because of the missing rendering of <f:flashMessages />.)


Related issues 3 (3 open0 closed)

Related to TYPO3 Core - Bug #93887: Ext:Form Caching Determination breaking Ajax RequestNewRalf Zimmermann2021-04-09

Actions
Related to TYPO3 Core - Bug #92406: Using formvh:render without extbase context results in ExceptionNewRalf Zimmermann2020-09-25

Actions
Related to TYPO3 Core - Bug #98084: Honeypot not working anymore?New2022-08-05

Actions
Actions #1

Updated by Elias Häußler almost 2 years ago

  • Related to Bug #93887: Ext:Form Caching Determination breaking Ajax Request added
Actions #2

Updated by Elias Häußler almost 2 years ago

  • Related to Bug #92406: Using formvh:render without extbase context results in Exception added
Actions #3

Updated by Oliver Hader almost 2 years ago

  • Related to Bug #98084: Honeypot not working anymore? added
Actions #4

Updated by Helmut Hummel 12 months ago

@Elias Häußler since #93887 was reverted. This can be closed, right?

Actions #5

Updated by Elias Häußler 12 months ago

@Helmut Hummel Sure, it can be closed. Thanks for the reminder! Can you close it? I seem to lack permissions.

Actions #6

Updated by Helmut Hummel 12 months ago

  • Status changed from New to Closed

@Elias Häußler Thanks for the quick feedback! I'm closing it now.

Actions

Also available in: Atom PDF