Project

General

Profile

Actions

Bug #98580

closed

PHP Warning: Undefined array key "updateReferenceIndex" in extbase/Classes/Persistence/Generic/Backend.php

Added by Bastian Stargazer almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extbase
Target version:
-
Start date:
2022-10-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
8.0
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

PHP Warning: Undefined array key "updateReferenceIndex" in /var/www/html/public/typo3/sysext/extbase/Classes/Persistence/Generic/Backend.php line 651

The $frameworkConfiguration looks like this:

array (
  'persistence' => array (
    'storagePid' => 0,
  ),
  'controllerConfiguration' => array (),
)

Solution:

if (($frameworkConfiguration['persistence']['updateReferenceIndex'] ?? null) === '1') {
  // ...
}

TYPO3 v11.5.17
PHP v8.0

Actions #1

Updated by Gerrit Code Review almost 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/76091

Actions #2

Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/76059

Actions #3

Updated by Chris Müller almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #4

Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF