Project

General

Profile

Actions

Bug #99654

closed

spamProtectEmailAddresses not working as expected inside html address elements

Added by Axel Hahn over 1 year ago. Updated 28 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2023-01-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
spamProtectEmailAddresses
Complexity:
Is Regression:
Sprint Focus:

Description

The Email obfuscation is not working when it is used in html <address> tags.
Example: (Address tag created by the RTE Editor)

<address class="address">
<p class="address-title"><strong>Name</strong></p>
<p class="address-address">Street<br />
Zip &amp; City</p>
<p class="address-phone">+49 1234 456-7890</p>
<p class="address-fax">+49 1234 456-7891</p>
<p class="address-email"><a href="mailto:john.doe@example.com">john.doe@example.com</a></p>
<p class="address-www"><a href="http://www.example.com">www.example.com</a></p>
</address>

Is still machine readable:
<a href="mailto:john.doe@example.com">john.doe@example.com</a>

whereas a snippet outside the address tag:

<p><a href="mailto:john.doe@example.com">john.doe@example.com</a></p>

becomse obfuscated:

<a href="javascript:linkTo_UnCryptMailto(%27ocknvq%2Clqjp0fqgBgzcorng0eqo%27);">john.doe(at)example.com</a>

The following typoscript settings are used:

config.spamProtectEmailAddresses = 2
config.spamProtectEmailAddresses_atSubst = (at)

Actions #1

Updated by Axel Hahn over 1 year ago

  • Description updated (diff)
Actions #2

Updated by Axel Hahn over 1 year ago

Same behavior in Typo3 v11

Actions #3

Updated by Benjamin Franzke 11 months ago

  • Parent task set to #99669
Actions #4

Updated by Benjamin Franzke 11 months ago

  • Parent task deleted (#99669)
Actions #5

Updated by Uwe Wiebach 5 months ago

I have noticed the same thing (TYPO3 v11). Also, internal links within the address tag are not parsed.

Actions #6

Updated by Georg Ringer 2 months ago

  • Status changed from New to Needs Feedback

tested this in v13 with the following content inside the bodytext field

<address class="address">
<p><strong>Name</strong></p>
<p><a href="t3://page?uid=252">Street</a><br />Zip &amp; City</p>
<p>+49 1234 456-7890</p>
<p>+49 1234 456-7891</p>
<p><a href="mailto:john.doe@example.com">john.doe@example.com</a></p>
<p><a href="http://www.example.com">www.example.com</a></p>
</address>

(added directly in the DB) and it works fine. can you share your configs and test it without any modifications?

Actions #7

Updated by Georg Ringer 28 days ago

  • Status changed from Needs Feedback to Closed

closing issue because lack of feedback. if the issue is still valid for you, please contact me via slack or create a new issue and reference this one

Actions

Also available in: Atom PDF