Project

General

Profile

Actions

Bug #100858

closed

Scheduler task execute button not working

Added by Spawoz Technologies Pvt Ltd. about 1 year ago. Updated 9 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
scheduler
Start date:
2023-05-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
12
PHP Version:
8.2
Tags:
Complexity:
Is Regression:
Sprint Focus:
Stabilization Sprint

Description

Hello,

I am facing a strange issue with TYPO3 12.4.1 LTS. I've setup a scheduler task in my custom extension and when I tried to manually execute this, the "Execute" & "Execute on next cron job" buttons are not working. When click on that, nothing happens.

Any patch or solution for this issue?

Thank you.


Files

Screenshot 2023-05-11 at 11.10.37 AM.png (46.9 KB) Screenshot 2023-05-11 at 11.10.37 AM.png Spawoz Technologies Pvt Ltd., 2023-05-11 06:10
clipboard-202305111932-wswxf.png (18.6 KB) clipboard-202305111932-wswxf.png Georg Ringer, 2023-05-11 17:32
Scheduler-TYPO3-CMS-12-4-1.mp4 (397 KB) Scheduler-TYPO3-CMS-12-4-1.mp4 Spawoz Technologies Pvt Ltd., 2023-05-12 05:26
Actions #1

Updated by Georg Ringer about 1 year ago

thanks for creating the issue!
there is nothing known yet, therefore asking some additional questions:

- do other commands work?
- the "execute on next cronjob" requires a proper cronjob setup. is that done? you can also check the toolbar, see screenshot

Actions #2

Updated by Spawoz Technologies Pvt Ltd. about 1 year ago

I checked the manual execution with the "Execute" button and any of the commands not working. The main problem is, when button clicks, nothing happens. No error in the console. So looks like the click handler is not available.

I confirmed this issue with the Slack channel and the same issue was reproduced.

Thank you.

Actions #3

Updated by Chris Müller about 1 year ago

Yes, I can confirm. Clicking on one of the buttons: nothing happens. Also no error in the browser console.

Actions #4

Updated by Benni Mack about 1 year ago

Chris Müller wrote in #note-3:

Yes, I can confirm. Clicking on one of the buttons: nothing happens. Also no error in the browser console.

What command are you executing? Just tried this with 12.4.1 and set up a recurring "Optimize MySQL database tables (scheduler)" scheduler task, which I can trigger on next execution or directly, a flash message shows up...

Actions #5

Updated by Spawoz Technologies Pvt Ltd. about 1 year ago

Hi Benni,

Please see the video recording for the same. I tried with both core tasks and custom tasks, nothing works. The click of the button not triggered.

Thank you,
Arun Chandran

Actions #6

Updated by Georg Ringer about 1 year ago

  • Status changed from Needs Feedback to Accepted

thanks for the video. it is about the mass editing icons, not the single ones

Actions #7

Updated by Spawoz Technologies Pvt Ltd. about 1 year ago

Yes, it is. Thank you for checking the issue.

Actions #8

Updated by Sybille Peters 12 months ago

Just to clarify: the problem is not related to a specific scheduler task but happens in general for multi selection mode if one of the tasks are selected and "Execute on next cron job" or "Execute" is executed.

The same problem exists for the task groups.

I could reproduce it in v13, not in v11.

As far as I can tell, one of the problems is that the buttons are not within a form. This used to be the case (in v11). There, the outer Fluid was Index.html which wrapped everything within a form.

In the newer version, the structure is different and the task list is wrapped in a form, the MultiRecordSelectionActions partial is not. If - just to test - this is moved to within the form, at least the Controller is called - but then the tasks get deleted because obviously, this is not yet correct.

Then there is the problem of where the task ids are set. This currently does not happen (see MultiRecordSelectionActions.html).

This is complicated further, because it is also possible to create task groups where the same partial is used and should also work.

Personally, I would rather remove the functionality (for now) of selecting multiple tasks if it does not work and clean up the extension to make it developer friendly and easily maintainable, but of course if this is fixed that would be preferable.

Actions #9

Updated by Benni Mack 12 months ago

  • Target version changed from 12 LTS to Candidate for patchlevel
Actions #10

Updated by Benni Mack 12 months ago

  • Sprint Focus set to Stabilization Sprint
Actions #11

Updated by Gerrit Code Review 9 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81020

Actions #12

Updated by Gerrit Code Review 9 months ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81020

Actions #13

Updated by Gerrit Code Review 9 months ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81020

Actions #14

Updated by Gerrit Code Review 9 months ago

Patch set 1 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81023

Actions #15

Updated by Benjamin Kott 9 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF