Project

General

Profile

Actions

Bug #101050

closed

Form finisher overrides problems with flexform sections

Added by David Mellen about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2023-06-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
12
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

in TYPO3 12 form finisher overrides don't show flex form sections correctly.
The fields of an array item are always visible, even if none items were added. This may lead to validation errors if the item fields are mandatory.
The following screenshots illustrate the problem with the emailToSender finisher, in v11 everything works fine:

v12:

v11:


Files


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Task #97126: Remove TCEforms array key in FlexFormClosed2022-03-07

Actions
Related to TYPO3 Core - Bug #102250: Form finisher translation language missing in FlexFormResolved2023-10-25

Actions
Actions #1

Updated by Axel Müller about 1 year ago

+1

TYPO3 12.4.2, cms-form 12..4.2
  1. create new Form with the form-editor (predefined form -> simple contact)
  2. place the form-plugin on a page
  3. edit it, klick "override finisher settings"

This Bug is not a "should have", it's a "showstopper" for forms.

Actions #2

Updated by Benni Mack 12 months ago

  • Related to Bug #101313: email-fieldname to override EmailToSender added
Actions #3

Updated by Jan Helke 11 months ago

I did a git bisect
It looks like the error was introduced by the following patch
https://review.typo3.org/c/Packages/TYPO3.CMS/+/73835

Actions #4

Updated by Christian Kuhn 11 months ago

  • Related to Task #97126: Remove TCEforms array key in FlexForm added
Actions #5

Updated by Gerrit Code Review 11 months ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80423

Actions #6

Updated by Jan Helke 11 months ago

  • Related to deleted (Bug #101313: email-fieldname to override EmailToSender)
Actions #7

Updated by Jan Helke 11 months ago

  • Category set to Form Framework
Actions #8

Updated by Gerrit Code Review 11 months ago

Patch set 1 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80363

Actions #9

Updated by Christian Kuhn 11 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #10

Updated by Nikita Hovratov 8 months ago

  • Related to Bug #102250: Form finisher translation language missing in FlexForm added
Actions

Also available in: Atom PDF