Project

General

Profile

Actions

Bug #101340

closed

Switching tab in linkbrowser displays an error

Added by Rémy DANIEL about 1 year ago. Updated 10 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2023-07-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Switching tab in linkbrowser displays an error :

Page tree error
Got unexpected response from the server. Please check logs for details.

This is because the ajax request of the "Pages" tab is not yet finished and get canceled.
It happens in a website with a big page tree.

Step to reproduce:
  1. add a sleep(2) in \TYPO3\CMS\Backend\Controller\Page\TreeController::fetchDataAction to simulate a big page tree
  2. in a text content, add a link
  3. switch rapidly to another tab of the link browser
  4. observes the error in the upper right corner of the BE

See attached screenshot


Files

Actions

Also available in: Atom PDF