Project

General

Profile

Actions

Bug #101540

closed

Submitting the page input field in recordlist pagination opens the first page in new window

Added by Andreas Kienast 12 months ago. Updated 11 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Start date:
2023-08-02
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
12
PHP Version:
Tags:
Complexity:
medium
Is Regression:
Yes
Sprint Focus:

Description

This is a really odd one: When the "Record List" module is opened, and a table with many records is opened in the single table view, a pagination is rendered with an input field where a user can enter a valid page number. If the user now submits the form, instead of reloading the record list, the first page in the table is opened in a new tab.

The issue is caused by the "View webpage" entry in the dropdown menu of the table row. The element is a button without an explicit type set, which makes it a submit button, that is also the first one in the form. Since another event handler is on that button, the page is opened in a new window.


Related issues 2 (1 open1 closed)

Related to TYPO3 Core - Bug #101276: Preview button has no function when no site config existsClosed2023-07-06

Actions
Related to TYPO3 Core - Feature #101549: Improve pagination of tables inside list module.New2023-08-03

Actions
Actions #1

Updated by Andreas Kienast 12 months ago

  • Related to Bug #101276: Preview button has no function when no site config exists added
Actions #2

Updated by Gerrit Code Review 12 months ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80304

Actions #3

Updated by Gerrit Code Review 12 months ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80304

Actions #4

Updated by Riccardo De Contardi 12 months ago

  • Related to Feature #101549: Improve pagination of tables inside list module. added
Actions #5

Updated by Gerrit Code Review 11 months ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80304

Actions #6

Updated by Gerrit Code Review 11 months ago

Patch set 1 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80898

Actions #7

Updated by Andreas Fernandez 11 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #8

Updated by Benni Mack 11 days ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF