Project

General

Profile

Actions

Bug #101878

closed

Image handling presets

Added by Robin Louis van Komen 9 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2023-09-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
12
PHP Version:
8.2
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

Since TYPO3 v12 I am unable to select any of the image handling presets in the install tool.
If I configure my setup manually, everything works, which means that everything is setup correctly in the server environment.
I've found that it comes down to some changes to the findGraphicsMagickInPaths and findImageMagick6InPaths methods in the following classes of the cms-install extension:
Classes/Configuration/Image/GraphicsMagickPreset.php
Classes/Configuration/Image/ImageMagick6Preset.php

These methods will now break the loop over the searchPaths if it finds on that is not a file or not executable, which in my case means that it only checks the first path (/usr/local/bin/) and then returns false.


Files


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #101687: Install Tool Configuration Presets broken for image handling settingsResolved2023-08-15

Actions
Actions #1

Updated by Robin Louis van Komen 9 months ago

  • Is duplicate of Bug #101687: Install Tool Configuration Presets broken for image handling settings added
Actions #2

Updated by Georg Ringer 9 months ago

  • Status changed from New to Needs Feedback

can you test if it works after applying the patch of the linked issue?

Actions #3

Updated by Stefan Bürk 9 months ago

@Robin Louis van Komen Related issue/patch has been released today.

Can you please recheck the issue with 12.4.6 if it is solved ?

Actions #4

Updated by Robin Louis van Komen 9 months ago

Stefan Bürk wrote in #note-3:

@Robin Louis van Komen Related issue/patch has been released today.

Can you please recheck the issue with 12.4.6 if it is solved ?

I can confirm that it indeed solved the issue! Thanks.

Actions #5

Updated by Riccardo De Contardi 6 months ago

  • Status changed from Needs Feedback to Closed

@@Robin Louis van Komen thank you for your feedback and sorry for this late reply.

I close this issue as solved. If you think that this is the wrong decision or experience the issue again please reopen it or open a new issue with a reference to this one.

Thank you

Actions

Also available in: Atom PDF