Project

General

Profile

Actions

Bug #102170

closed

Epic #99669: CKEditor5 Collection

CKEditor5: wordCount plugin does not work after updating to TYPO3 v12.4.7

Added by Jasmina Ließmann 6 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Category:
RTE (rtehtmlarea + ckeditor)
Start date:
2023-10-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
12
PHP Version:
8.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

As described in file "typo3/sysext/rte_ckeditor/Configuration/RTE/Editor/Plugins.yaml", the CKEditor wordCount plugin can be activated with the following setting:

# Configure global wordCount plugin defaults
# Overwrite them in your RTE presets as it is necessary
wordCount:
  displayWords: true
  displayCharacters: true

After updating to TYPO3 v12.4.7, these settings no longer seem to apply, so the number of words and characters are no longer displayed below the RTE. This was still functional with TYPO3 v12.4.6.


Files

ckeditor-wordcount-12.4.6.jpg (62.2 KB) ckeditor-wordcount-12.4.6.jpg Jasmina Ließmann, 2023-10-14 12:12
ckeditor-wordcount-12.4.7.jpg (60.2 KB) ckeditor-wordcount-12.4.7.jpg Jasmina Ließmann, 2023-10-14 12:12

Related issues 1 (1 open0 closed)

Related to TYPO3 Core - Task #102082: CKEditor5 - Re-add ability to set maximum allowed char countAcceptedJosef Glatz2023-10-04

Actions
Actions #1

Updated by Jasmina Ließmann 6 months ago

  • Related to Task #102082: CKEditor5 - Re-add ability to set maximum allowed char count added
Actions #2

Updated by Benjamin Franzke 6 months ago

  • Assignee set to Benjamin Franzke
Actions #3

Updated by Benjamin Franzke 6 months ago

  • Status changed from New to Rejected

Hi, you are right, we changed the wordcount plugin to be an opt-in as in v11 (for proper v11 backwards compatibility)

That means wordcount needs to be loaded either via the legacy config:

editor:
  config:
    extraPlugins:
      - wordcount

Or via the newer importModules syntax:

editor:
  config:
    importModules:
      - { module: '@ckeditor/ckeditor5-word-count', exports: ['WordCount'] }

I guess it's likely that most people "copy" their existing v11 configurations also into (new) v12 configurations, so it's likely that those, who intended for wordcount to be enabled, have extraPlugins[] = wordcount defined.

Hope it's fine to close this ticket for that reason?

Actions #4

Updated by Jasmina Ließmann 6 months ago

  • Status changed from Rejected to Closed

Yes, it's fine for me now. Thanks for the clarification. I'm closing the ticket.

Actions #5

Updated by Sebastian Schmal 3 months ago

perfect with importModules. please edit the TYPO3 Doc.

Actions

Also available in: Atom PDF