Project

General

Profile

Actions

Bug #102574

closed

Pages Tree : Drag New doktype created with Extbase does not work in Firefox

Added by Regis TEDONE 7 months ago. Updated 14 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2023-11-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
12
PHP Version:
8.2
Tags:
Complexity:
medium
Is Regression:
Yes
Sprint Focus:

Description

TYPO3 V12.4.8

BROWSER FIREFOX 102

After adding a new doktype with extbase, the drag and drop behavior for this new doktype, over the Pages tree, always show forbidden icon.
It works well under Chrome.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #98439: Drag&Drop broken for custom page types in Firefox 91.13.0esr (64-Bit)Closed2022-09-27

Actions
Actions #1

Updated by Chris Müller 7 months ago

I am curious, how do you create a new doktype via Extbase? AFAIK this is just a configuration in ext_tables.php/TCA overrides?

Actions #2

Updated by Oliver Bartsch 7 months ago

  • Status changed from New to Needs Feedback
Actions #3

Updated by Regis TEDONE 7 months ago · Edited

Using the PageDoktypeRegistry class in the ext_tables.php of an extension :


$dokTypeRegistry = GeneralUtility::makeInstance(PageDoktypeRegistry::class);
$dokTypeRegistry->add($doktype,
  [
   'type' => 'web',
   'allowedTables' => '*',
  ]
);

Actions #4

Updated by Christian Kuhn 4 months ago

  • Related to Bug #98439: Drag&Drop broken for custom page types in Firefox 91.13.0esr (64-Bit) added
Actions #5

Updated by Riccardo De Contardi 3 months ago · Edited

I tried to reproduce it with the demo site https://demo.typo3.org/typo3 but I failed...
(Firefox 124.0.1 (64 bit) on MAC)

Actions #6

Updated by Riccardo De Contardi 14 days ago

  • Status changed from Needs Feedback to Closed

I close this issue as I am not able to reproduce it on version 12; I followed the guide https://docs.typo3.org/m/typo3/reference-coreapi/main/en-us/ApiOverview/PageTypes/CreateNewPageType.html
to add a custom page doktype.

If you think that this is the wrong decision or experience the issue again please open a new issue with a reference to this one. Thank you.

Actions

Also available in: Atom PDF