Project

General

Profile

Actions

Bug #103828

closed

Copy-Paste: Prevent orphaned

Added by André Buchmann about 1 month ago. Updated 22 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2024-05-13
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
13
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

See detailed Problem description here: https://forge.typo3.org/issues/102345

Here we focus on the copy-paste behavior only. Moving records should be solved separately!


Related issues 4 (2 open2 closed)

Related to TYPO3 Core - Bug #102345: Copy/Move pages with existing translation into another site with different language setup results in orphaned problematic page translation recordsUnder Review2023-11-07

Actions
Related to TYPO3 Core - Task #103912: Clean up DH->copyL10nOverlayRecords()Resolved2024-05-25

Actions
Related to TYPO3 Core - Bug #93744: Copying pages with translations to sites without translations should not copy translationsNew2021-03-15

Actions
Has duplicate TYPO3 Core - Bug #104010: Copy & Paste creates invisible translationsClosed2024-06-10

Actions
Actions #1

Updated by André Buchmann about 1 month ago

  • Private changed from Yes to No
Actions #2

Updated by Gerrit Code Review about 1 month ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/84237

Actions #3

Updated by Gerrit Code Review about 1 month ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/84237

Actions #4

Updated by André Buchmann about 1 month ago

  • Related to Bug #102345: Copy/Move pages with existing translation into another site with different language setup results in orphaned problematic page translation records added
Actions #5

Updated by Gerrit Code Review 22 days ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/84237

Actions #6

Updated by André Buchmann 22 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #7

Updated by Christian Kuhn 22 days ago

  • Related to Task #103912: Clean up DH->copyL10nOverlayRecords() added
Actions #8

Updated by André Buchmann 6 days ago

  • Is duplicate of Bug #93744: Copying pages with translations to sites without translations should not copy translations added
Actions #9

Updated by André Buchmann 6 days ago

  • Is duplicate of deleted (Bug #93744: Copying pages with translations to sites without translations should not copy translations)
Actions #10

Updated by André Buchmann 6 days ago

  • Related to Bug #93744: Copying pages with translations to sites without translations should not copy translations added
Actions #11

Updated by André Buchmann 1 day ago

  • Has duplicate Bug #104010: Copy & Paste creates invisible translations added
Actions

Also available in: Atom PDF