Project

General

Profile

Actions

Bug #104010

closed

Copy & Paste creates invisible translations

Added by Lukas Fürderer about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2024-06-10
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
8.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Copying & Pasting content elements can create invisible content elements. They are invisible because they exist in a language without a corresponding translated page.

This can be reproduced, for example on demo.typo3.org:

- Create a content element on page A in the default language (english) and one translation (german) using "Connected" mode.
- Create a page B, but only in english, without a german page translation
- Copy the english content element from page A to page B.
(There is now an invisible german translation of the pasted element)
- Translate the page to german
(Now the element becomes visible)

I expect that content elements do never exist without a corresponding page. When I translate a page, it should always be initially empty.


Related issues 5 (4 open1 closed)

Related to TYPO3 Core - Bug #90610: Copy-pasting a record that's already translated in "connected" mode, to a different language causing "free" mode, creates duplicate(s) in "connected" translationsNew2020-03-01

Actions
Related to TYPO3 Core - Bug #93744: Copying pages with translations to sites without translations should not copy translationsNew2021-03-15

Actions
Related to TYPO3 Core - Bug #102345: Copy/Move pages with existing translation into another site with different language setup results in orphaned problematic page translation recordsUnder Review2023-11-07

Actions
Related to TYPO3 Core - Task #103525: Sorting of translated content elements after copy&paste and with no page translationNew2024-04-03

Actions
Is duplicate of TYPO3 Core - Bug #103828: Copy-Paste: Prevent orphaned Closed2024-05-13

Actions
Actions #1

Updated by Lukas Fürderer about 2 months ago

  • Related to Bug #90610: Copy-pasting a record that's already translated in "connected" mode, to a different language causing "free" mode, creates duplicate(s) in "connected" translations added
  • Related to Bug #93744: Copying pages with translations to sites without translations should not copy translations added
  • Related to Bug #102345: Copy/Move pages with existing translation into another site with different language setup results in orphaned problematic page translation records added
  • Related to Task #103525: Sorting of translated content elements after copy&paste and with no page translation added
Actions #2

Updated by André Buchmann about 1 month ago

  • Is duplicate of Bug #103828: Copy-Paste: Prevent orphaned added
Actions #3

Updated by André Buchmann about 1 month ago

  • Status changed from New to Closed

Heyho @Lukas Fürderer

thank you for the bug report. I can confirm this issue. It has been solved for TYPO3 13 a few weeks ago with #103828 .

There will be no backport for TYPO3 12 or 11. You can have a look at the patch and try to backport it for you project using e.g. composer patches.

Closing the issue as it's a duplicate.

Best regards
André

Actions

Also available in: Atom PDF