Bug #90610


Copy-pasting a record that's already translated in "connected" mode, to a different language causing "free" mode, creates duplicate(s) in "connected" translations

Added by Claus Due about 4 years ago. Updated over 3 years ago.

Should have
Target version:
Start date:
Due date:
% Done:


Estimated time:
TYPO3 Version:
PHP Version:
Is Regression:
Sprint Focus:


Steps to reproduce:

  • Have at least three languages.
  • Start with an empty page translated to at least three languages.
  • Create content record in original language.
  • Translate to "Connected" mode for one language.
  • Copy (context-menu "copy") the original language version.
  • Click the "paste" icon in a third language.


  • One "free mode" copy of the original language record is created in the third language.
  • Visually - one content record exists in each of three languages; one in original language, one in "connected" mode language and one in "free" mode language.

Observed incorrect behavior:

  • One "free mode" copy of the original language record is created in the third language
  • All translated versions of original language record now have a duplicate
  • Visually - one content record exists in original language, TWO exist in "connected" mode language, one exists in "free" mode language.


  • TYPO3 perceives the "paste" operation to a different language the same as had the record been pasted in original language.
  • TYPO3 therefore attempts to synchronise localized versions of the copy when it should be disconnected; exists in a different language that is NOT the source of localisation.

Related issues 1 (1 open0 closed)

Related to TYPO3 Core - Story #101561: DataHandler related translation issuesNew2023-08-03

Actions #1

Updated by Claus Due about 4 years ago

Possible solution could be to somehow pass $ignoreLocalization = true to \TYPO3\CMS\Core\DataHandling\DataHandler::copyRecord when pasting to a different language - however, this does not appear to be supported through the way the "paste" icon and corresponding JS action is currently implemented.

The source of the problem seems to be that that \TYPO3\CMS\Core\DataHandling\DataHandler::copyL10nOverlayRecords is called which is called whenever $ignoreLocalization is false or $language is zero. when calling \TYPO3\CMS\Core\DataHandling\DataHandler::copyRecord. Perhaps most appropriately solved by passing the right $language to \TYPO3\CMS\Core\DataHandling\DataHandler::copyRecord when pasting a record to a different language.

Actions #2

Updated by Christian Eßl about 4 years ago

Same problem with "mixed mode" columns.
From what I see, this behaviour is present in TYPO3 8, 9 and 10 and older.
I even tried the same copy/paste procedure to a translation column in an old 6.2 instance, and the record was copied to all present languages.

Actions #3

Updated by Jonas Eberle over 3 years ago

  • Category set to Localization
Actions #4

Updated by Astrid Haubold 6 months ago

  • Related to Story #101561: DataHandler related translation issues added

Also available in: Atom PDF